# CVE-2026-46683: Snappy: SSRF and local file read via the xsl-style-sheet option

> Attackers can exploit the xsl-style-sheet option to perform Server-Side Request Forgery and read local files in Snappy.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-c5fp-p67m-gq56

## What is CVE-2026-46683?

CVE-2026-46683 is a medium-severity server-side request forgery vulnerability in KnpLabs snappy, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.7.0, there is a SSRF and local file read vulnerability via the xsl-style-sheet option. This issue has been patched in version 1.7.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-46683?

2 open source packages ship an affected version, including knplabs/knp-snappy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knplabs/knp-snappy` | Packagist | All versions | 1.7.0 |
| `knplabs/knp-snappy` | Packagist | All versions | 1.7.0 |

## How do I fix CVE-2026-46683?

Upgrade knplabs/knp-snappy to 1.7.0 or later.

## Is CVE-2026-46683 being exploited?

There is no known exploitation of CVE-2026-46683 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46683 and fix it if it is affected.

What it is: CVE-2026-46683 is a medium-severity server-side request forgery vulnerability in KnpLabs snappy, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46683 in the wild and no public exploit code.

Affected packages and fixed versions:
- knplabs/knp-snappy (Packagist): affected all versions; fixed in 1.7.0
- knplabs/knp-snappy (Packagist): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46683/ (Markdown: https://insights.sbomify.com/CVE-2026-46683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46683
- OSV: https://osv.dev/vulnerability/CVE-2026-46683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46683/
Summaries are generated and may contain mistakes; the official description above is the record.
