# CVE-2026-46695: BoxLite: Permission Bypass in boxlite Allows Modification of Read-Only Files

> Attackers can bypass read-only restrictions in BoxLite containers to modify files by exploiting unrestricted kernel capabilities.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-g6ww-w5j2-r7x3, GO-2026-5392, PYSEC-2026-299, RUSTSEC-2026-0147

## What is CVE-2026-46695?

CVE-2026-46695 is a critical vulnerability in boxlite-ai boxlite, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Boxlite is a sandbox service that allows users to create lightweight virtual machines (Boxes) and launch OCI containers within them to run untrusted code. Prior to version 0.9.0, Boxlite does not restrict the kernel capabilities available inside the container, malicious code can remount the directory in rw mode, thereby gaining write access to that directory. This allows malicious code to perform arbitrary write operations on directories that should be read-only. This issue has been patched in version 0.9.0.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-46695?

13 open source packages ship an affected version, including github.com/boxlite-ai/boxlite/sdks/go, boxlite and boxlite-cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/boxlite-ai/boxlite/sdks/go` | Go | All versions | 0.9.0 |
| `github.com/boxlite-ai/boxlite/sdks/go` | Go | All versions | 0.9.0 |
| `github.com/boxlite-ai/boxlite/sdks/go` | Go | All versions | 0.9.0 |
| `boxlite` | PyPI | All versions | 0.9.0 |
| `boxlite` | PyPI | All versions | 0.9.0 |
| `boxlite` | PyPI | All versions | 0.9.0 |
| `boxlite` | crates.io | All versions | 0.9.0 |
| `boxlite` | crates.io | All versions | 0.9.0 |
| `boxlite` | crates.io | From 0.0.0-0 | 0.9.0 |
| `boxlite-cli` | crates.io | All versions | 0.9.0 |
| `boxlite-cli` | crates.io | All versions | 0.9.0 |
| `@boxlite-ai/boxlite` | npm | All versions | 0.9.0 |
| `@boxlite-ai/boxlite` | npm | All versions | 0.9.0 |

## How do I fix CVE-2026-46695?

Upgrade github.com/boxlite-ai/boxlite/sdks/go to 0.9.0 or later.

## Is CVE-2026-46695 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46695 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46695 and fix it if it is affected.

What it is: CVE-2026-46695 is a critical vulnerability in boxlite-ai boxlite, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46695 exists.

Affected packages and fixed versions:
- github.com/boxlite-ai/boxlite/sdks/go (Go): affected all versions; fixed in 0.9.0
- github.com/boxlite-ai/boxlite/sdks/go (Go): affected all versions; fixed in 0.9.0
- github.com/boxlite-ai/boxlite/sdks/go (Go): affected all versions; fixed in 0.9.0
- boxlite (PyPI): affected all versions; fixed in 0.9.0
- boxlite (PyPI): affected all versions; fixed in 0.9.0
- boxlite (PyPI): affected all versions; fixed in 0.9.0
- boxlite (crates.io): affected all versions; fixed in 0.9.0
- boxlite (crates.io): affected all versions; fixed in 0.9.0
- boxlite (crates.io): affected from 0.0.0-0; fixed in 0.9.0
- boxlite-cli (crates.io): affected all versions; fixed in 0.9.0
- boxlite-cli (crates.io): affected all versions; fixed in 0.9.0
- @boxlite-ai/boxlite (npm): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46695/ (Markdown: https://insights.sbomify.com/CVE-2026-46695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46695
- OSV: https://osv.dev/vulnerability/CVE-2026-46695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46695/
Summaries are generated and may contain mistakes; the official description above is the record.
