# CVE-2026-46697: Fediverse Embeds: Unauthenticated SSRF / open proxy via REST media-proxy endpoint

> An unauthenticated attacker can exploit an SSRF vulnerability in the Fediverse Embeds WordPress plugin to read internal resources or use the site as an open proxy.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-mpq6-hjh3-m543

## What is CVE-2026-46697?

CVE-2026-46697 is a high-severity server-side request forgery vulnerability in stefanbohacek fediverse-embeds-wordpress-plugin, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fediverse Embeds embeds fediverse posts on WordPress sites. Prior to version 1.5.8, Fediverse Embeds registered an unauthenticated REST route ftf/media-proxy (includes/Media_Proxy.php) with permission_callback => __return_true that accepted a base64-encoded URL and forwarded it to wp_remote_get($url) without enforcing any allowlist. The plugin's source contained a comment block explicitly acknowledging that the request should be validated against allowed fediverse domains, but in 1.5.7 the validation only set a local $can_download_media flag that was never read. The full response body was echoed back to the caller, so this was a full-read SSRF / open proxy reachable by any anonymous visitor. This issue has been patched in version 1.5.8.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-46697?


## How do I fix CVE-2026-46697?

No fix has been published for CVE-2026-46697 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46697 being exploited?

There is no known exploitation of CVE-2026-46697 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46697 and fix it if it is affected.

What it is: CVE-2026-46697 is a high-severity server-side request forgery vulnerability in stefanbohacek fediverse-embeds-wordpress-plugin, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46697 in the wild and no public exploit code.

Affected product: stefanbohacek fediverse-embeds-wordpress-plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46697/ (Markdown: https://insights.sbomify.com/CVE-2026-46697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46697
- OSV: https://osv.dev/vulnerability/CVE-2026-46697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46697/
Summaries are generated and may contain mistakes; the official description above is the record.
