{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46698 exists.","fix":"No fix has been published for CVE-2026-46698 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-46698 is a medium-severity server-side request forgery vulnerability in stefanbohacek fediverse-embeds-wordpress-plugin, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46698 and fix it if it is affected.\n\nWhat it is: CVE-2026-46698 is a medium-severity server-side request forgery vulnerability in stefanbohacek fediverse-embeds-wordpress-plugin, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46698 exists.\n\nAffected product: stefanbohacek fediverse-embeds-wordpress-plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46698/ (Markdown: https://insights.sbomify.com/CVE-2026-46698/index.md)","id":"CVE-2026-46698","markdown":"https://insights.sbomify.com/CVE-2026-46698/index.md","name":"CVE-2026-46698","record":{"aliases":["GHSA-cr42-rgq6-whjh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"An unauthenticated attacker can exploit a public nonce to trigger Server-Side Request Forgery in the Fediverse Embeds WordPress plugin.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Fediverse Embeds embeds fediverse posts on WordPress sites. Prior to version 1.5.9, Fediverse Embeds registered the unauthenticated AJAX action wp_ajax_nopriv_ftf_get_site_info (includes/Site_Info.php) that verified a nonce ftf-fediverse-embeds-nonce and then called file_get_html($site_url) on the attacker-supplied URL. The same nonce was enqueued onto every public page containing a fediverse embed (via includes/Enqueue_Assets.php lines 41-46 + includes/Helpers.php lines 64-83), so the nonce gate was not an authentication boundary; any visitor of a public post with an embed could grab it and reuse it. This issue has been patched in version 1.5.9.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Fediverse Embeds: Public-nonce SSRF via ftf_get_site_info AJAX action","id":"CVE-2026-46698","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Auth bypass in conda-smithy","id":"CVE-2026-46699"},"packages":[],"prev":{"headline":"Fediverse Embeds: Unauthenticated SSRF / open proxy via REST media-proxy endpoint","id":"CVE-2026-46697"},"products":["fediverse-embeds-wordpress-plugin"],"published":"2026-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-11","vendors":["stefanbohacek"]},"summary":"An unauthenticated attacker can exploit a public nonce to trigger Server-Side Request Forgery in the Fediverse Embeds WordPress plugin.","url":"https://insights.sbomify.com/CVE-2026-46698/"}