# CVE-2026-46698: Fediverse Embeds: Public-nonce SSRF via ftf_get_site_info AJAX action

> An unauthenticated attacker can exploit a public nonce to trigger Server-Side Request Forgery in the Fediverse Embeds WordPress plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-cr42-rgq6-whjh

## What is CVE-2026-46698?

CVE-2026-46698 is a medium-severity server-side request forgery vulnerability in stefanbohacek fediverse-embeds-wordpress-plugin, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fediverse Embeds embeds fediverse posts on WordPress sites. Prior to version 1.5.9, Fediverse Embeds registered the unauthenticated AJAX action wp_ajax_nopriv_ftf_get_site_info (includes/Site_Info.php) that verified a nonce ftf-fediverse-embeds-nonce and then called file_get_html($site_url) on the attacker-supplied URL. The same nonce was enqueued onto every public page containing a fediverse embed (via includes/Enqueue_Assets.php lines 41-46 + includes/Helpers.php lines 64-83), so the nonce gate was not an authentication boundary; any visitor of a public post with an embed could grab it and reuse it. This issue has been patched in version 1.5.9.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-46698?


## How do I fix CVE-2026-46698?

No fix has been published for CVE-2026-46698 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46698 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46698 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46698 and fix it if it is affected.

What it is: CVE-2026-46698 is a medium-severity server-side request forgery vulnerability in stefanbohacek fediverse-embeds-wordpress-plugin, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46698 exists.

Affected product: stefanbohacek fediverse-embeds-wordpress-plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46698/ (Markdown: https://insights.sbomify.com/CVE-2026-46698/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46698
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46698
- OSV: https://osv.dev/vulnerability/CVE-2026-46698

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46698/
Summaries are generated and may contain mistakes; the official description above is the record.
