# CVE-2026-46700: @actual-app/sync-server's missing authorization on GET /secret/:name allows non-admin OpenID users to enumerate admin-configured bank-sync secrets

> Non-admin users can enumerate admin-configured bank-sync secrets due to missing authorization checks on the secrets endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-3f62-qv96-4p78

## What is CVE-2026-46700?

CVE-2026-46700 is a medium-severity missing authorization vulnerability in actualbudget actual, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Actual is a local-first personal finance tool. Prior to 26.6.0, the GET /secret/:name endpoint in @actual-app/sync-server checks only that the caller has a valid session and does not verify the caller is an admin, while the sibling POST /secret/ handler enforces an admin check in OpenID mode. Any authenticated non-admin BASIC user in OpenID multi-user deployments can probe the secrets store and learn which admin-managed bank-sync integrations have been configured, including simplefin_accessKey, pluggyai_clientSecret, pluggyai_itemIds, and the gocardless secrets. This issue is fixed in version 26.6.0.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-46700?

2 open source packages ship an affected version, including @actual-app/sync-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@actual-app/sync-server` | npm | All versions | 26.6.0 |
| `@actual-app/sync-server` | npm | All versions | 26.6.0 |

## How do I fix CVE-2026-46700?

Upgrade @actual-app/sync-server to 26.6.0 or later.

## Is CVE-2026-46700 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46700 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46700 and fix it if it is affected.

What it is: CVE-2026-46700 is a medium-severity missing authorization vulnerability in actualbudget actual, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46700 exists.

Affected packages and fixed versions:
- @actual-app/sync-server (npm): affected all versions; fixed in 26.6.0
- @actual-app/sync-server (npm): affected all versions; fixed in 26.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46700/ (Markdown: https://insights.sbomify.com/CVE-2026-46700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46700
- OSV: https://osv.dev/vulnerability/CVE-2026-46700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46700/
Summaries are generated and may contain mistakes; the official description above is the record.
