# CVE-2026-46701: Network-AI: Unauthenticated Cross-Origin MCP Tool Invocation via Empty Default Secret

> Unauthenticated attackers can invoke MCP tools on default-configured Network-AI servers due to an empty secret and permissive CORS, enabling remote code execution and data modification.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-j3vx-cx2r-pvg8

## What is CVE-2026-46701?

CVE-2026-46701 is a high-severity authentication bypass vulnerability in Jovancoding Network-AI, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Network-AI is a TypeScript/Node.js multi-agent orchestrator. Prior to version 5.4.5, the MCP SSE server defaults to an empty secret (`process.env['NETWORK_AI_MCP_SECRET'] ?? ''` at `bin/mcp-server.ts:89`), which causes `_isAuthorized` (`lib/mcp-transport-sse.ts:254`) to return `true` unconditionally for every request — no `Authorization` header is required. Simultaneously, `_handleRequest` sets `Access-Control-Allow-Origin: *` (`lib/mcp-transport-sse.ts:272`) on every response, so a cross-origin browser fetch can read the result without restriction. An unauthenticated attacker who can lure a user to a malicious web page can invoke all 22 exposed MCP tools — including `config_set`, `agent_spawn`, and `blackboard_write` — against a default-configured localhost server. Version 5.4.5 patches the issue.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-46701?

2 open source packages ship an affected version, including network-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `network-ai` | npm | All versions | 5.4.5 |
| `network-ai` | npm | All versions | 5.4.5 |

Products: Network-Ai Network-Ai.

## How do I fix CVE-2026-46701?

Upgrade network-ai to 5.4.5 or later.

## Is CVE-2026-46701 being exploited?

There is no known exploitation of CVE-2026-46701 in the wild and no public exploit code.

## Other vulnerabilities in Jovancoding Network-AI

- [CVE-2026-58484](https://insights.sbomify.com/CVE-2026-58484/): Network-AI: Poisoned environment backup manifest allows arbitrary recursive deletion during backup pruning (high 7.1)
- [CVE-2026-58481](https://insights.sbomify.com/CVE-2026-58481/): Network-AI: AgentRuntime sandbox path-prefix checks allow file access outside the configured base directory (medium 6.5)
- [CVE-2026-58413](https://insights.sbomify.com/CVE-2026-58413/): EnvironmentManager.restore() backup ID path traversal copies arbitrary directories into environment data (medium 6.1)
- [CVE-2026-58482](https://insights.sbomify.com/CVE-2026-58482/): Network-AI: ApprovalInbox HTTP server has no authentication — anyone can approve pending agent actions (medium 5.9)
- [CVE-2026-58414](https://insights.sbomify.com/CVE-2026-58414/): Network-AI: EnvironmentManager.backup() follows symlinked directories and copies files outside the environment root into backups (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46701 and fix it if it is affected.

What it is: CVE-2026-46701 is a high-severity authentication bypass vulnerability in Jovancoding Network-AI, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46701 in the wild and no public exploit code.

Affected packages and fixed versions:
- network-ai (npm): affected all versions; fixed in 5.4.5
- network-ai (npm): affected all versions; fixed in 5.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46701/ (Markdown: https://insights.sbomify.com/CVE-2026-46701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46701
- OSV: https://osv.dev/vulnerability/CVE-2026-46701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46701/
Summaries are generated and may contain mistakes; the official description above is the record.
