CVE-2026-46702 Russh: Post-decompression SSH packet size was not bounded, allowing remote oversized compressed packets
Remote attackers can cause denial of service by sending oversized compressed SSH packets when compression is enabled in the Russh library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-46702?
CVE-2026-46702 is a high-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Russh is a Rust SSH client & server library. From version 0.34.0 to before version 0.61.1, when SSH compression is enabled, russh accepted compressed packets whose on-wire size passed the normal transport packet-length checks but whose decompressed size was much larger. This allowed a remote peer to send oversized post-decompression packets that should have been rejected. In current releases, this is a remote denial-of-service / resource-exhaustion issue in the post-decompression receive path. In older releases before 0.58.0, the same remote decompression path used CryptoVec, which appears to make the historical impact worse. This issue has been patched in version 0.61.1.
Weakness: CWE-770
Which versions are affected by CVE-2026-46702?
2 open source packages ship an affected version, including russh.
| Package | Affected | Fixed in |
|---|---|---|
russh crates.io | From 0.34.0 | 0.61.1 |
russh crates.io | From 0.34.0 | 0.61.1 |
How do I fix CVE-2026-46702?
Upgrade russh to 0.61.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-46702 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46702 exists.
Sources
Also known as DEBIAN-CVE-2026-46702, GHSA-wwx6-x28x-8259.