{"answers":{"affected":"2 open source packages ship an affected version, including russh.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46702 exists.","fix":"Upgrade russh to 0.61.1 or later.","what":"CVE-2026-46702 is a high-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46702 and fix it if it is affected.\n\nWhat it is: CVE-2026-46702 is a high-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46702 exists.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected from 0.34.0; fixed in 0.61.1\n- russh (crates.io): affected from 0.34.0; fixed in 0.61.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46702/ (Markdown: https://insights.sbomify.com/CVE-2026-46702/index.md)","id":"CVE-2026-46702","markdown":"https://insights.sbomify.com/CVE-2026-46702/index.md","name":"CVE-2026-46702","record":{"aliases":["DEBIAN-CVE-2026-46702","GHSA-wwx6-x28x-8259"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Rust SSH library","requires_auth":"none","summary":"Remote attackers can cause denial of service by sending oversized compressed SSH packets when compression is enabled in the Russh library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Russh is a Rust SSH client \u0026 server library. From version 0.34.0 to before version 0.61.1, when SSH compression is enabled, russh accepted compressed packets whose on-wire size passed the normal transport packet-length checks but whose decompressed size was much larger. This allowed a remote peer to send oversized post-decompression packets that should have been rejected. In current releases, this is a remote denial-of-service / resource-exhaustion issue in the post-decompression receive path. In older releases before 0.58.0, the same remote decompression path used CryptoVec, which appears to make the historical impact worse. This issue has been patched in version 0.61.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Russh: Post-decompression SSH packet size was not bounded, allowing remote oversized compressed packets","id":"CVE-2026-46702","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"BoxLite: Path Traversal Vulnerability in boxlite Leads to Arbitrary File Write on the Host","id":"CVE-2026-46703"},"packages":[{"ecosystem":"crates.io","fixed":["0.61.1"],"introduced":["0.34.0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-wwx6-x28x-8259"},{"ecosystem":"crates.io","fixed":["0.61.1"],"introduced":["0.34.0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-wwx6-x28x-8259"}],"prev":{"headline":"Network-AI: Unauthenticated Cross-Origin MCP Tool Invocation via Empty Default Secret","id":"CVE-2026-46701"},"products":["russh"],"published":"2026-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-11","vendors":["Eugeny"]},"summary":"Remote attackers can cause denial of service by sending oversized compressed SSH packets when compression is enabled in the Russh library.","url":"https://insights.sbomify.com/CVE-2026-46702/"}