# CVE-2026-46702: Russh: Post-decompression SSH packet size was not bounded, allowing remote oversized compressed packets

> Remote attackers can cause denial of service by sending oversized compressed SSH packets when compression is enabled in the Russh library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-46702, GHSA-wwx6-x28x-8259

## What is CVE-2026-46702?

CVE-2026-46702 is a high-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Russh is a Rust SSH client & server library. From version 0.34.0 to before version 0.61.1, when SSH compression is enabled, russh accepted compressed packets whose on-wire size passed the normal transport packet-length checks but whose decompressed size was much larger. This allowed a remote peer to send oversized post-decompression packets that should have been rejected. In current releases, this is a remote denial-of-service / resource-exhaustion issue in the post-decompression receive path. In older releases before 0.58.0, the same remote decompression path used CryptoVec, which appears to make the historical impact worse. This issue has been patched in version 0.61.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-46702?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | From 0.34.0 | 0.61.1 |
| `russh` | crates.io | From 0.34.0 | 0.61.1 |

## How do I fix CVE-2026-46702?

Upgrade russh to 0.61.1 or later.

## Is CVE-2026-46702 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46702 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46702 and fix it if it is affected.

What it is: CVE-2026-46702 is a high-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46702 exists.

Affected packages and fixed versions:
- russh (crates.io): affected from 0.34.0; fixed in 0.61.1
- russh (crates.io): affected from 0.34.0; fixed in 0.61.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46702/ (Markdown: https://insights.sbomify.com/CVE-2026-46702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46702
- OSV: https://osv.dev/vulnerability/CVE-2026-46702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46702/
Summaries are generated and may contain mistakes; the official description above is the record.
