# CVE-2026-46705: russh server userauth state is not reset when authentication principal changes

> Attackers can bypass authentication checks in russh SSH servers by exploiting state persistence when changing user or service names during login.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-46705, GHSA-hpv4-5h6f-wqr3

## What is CVE-2026-46705?

CVE-2026-46705 is a medium-severity authentication bypass vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Russh is a Rust SSH client & server library. From version 0.34.0-beta.1 to before version 0.61.0, the russh server authentication path keeps internal userauth state across SSH_MSG_USERAUTH_REQUEST messages without separating that state when the request principal changes. RFC 4252 allows the user name and service name fields to change between authentication requests. The issue is not that such changes are invalid. The issue is that russh-owned authentication state, such as remaining methods, partial-success state, and in-progress method state, can remain associated with the connection and then influence a later request for a different (user, service). This is an internal library state mismatch. This issue has been patched in version 0.61.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-46705?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | From 0.34.0-beta.1 | 0.61.0 |
| `russh` | crates.io | From 0.34.0-beta.1 | 0.61.0 |

## How do I fix CVE-2026-46705?

Upgrade russh to 0.61.0 or later.

## Is CVE-2026-46705 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46705 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46705 and fix it if it is affected.

What it is: CVE-2026-46705 is a medium-severity authentication bypass vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46705 exists.

Affected packages and fixed versions:
- russh (crates.io): affected from 0.34.0-beta.1; fixed in 0.61.0
- russh (crates.io): affected from 0.34.0-beta.1; fixed in 0.61.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46705/ (Markdown: https://insights.sbomify.com/CVE-2026-46705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46705
- OSV: https://osv.dev/vulnerability/CVE-2026-46705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46705/
Summaries are generated and may contain mistakes; the official description above is the record.
