# CVE-2026-46708: EspoCRM: Target list Opt-Out actions allows opting out record without access Target List and access to record

> A low-privileged user can modify the opt-out status of protected contacts or leads they cannot otherwise access, bypassing record-level authorization checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-mqp6-23xq-7q3r

## What is CVE-2026-46708?

CVE-2026-46708 is a medium-severity missing authorization vulnerability in espocrm, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

EspoCRM is an open source customer relationship management application. Prior to 9.3.7, a low-privileged user who can access a shared TargetList can invoke opt-out or cancel-opt-out actions for a protected Contact or Lead that the user cannot read or edit. The service validates access to the target list but retrieves the target record without the required record authorization, allowing unauthorized changes to its opted_out relationship state. This issue is fixed in version 9.3.7.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-46708?


## How do I fix CVE-2026-46708?

No fix has been published for CVE-2026-46708 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46708 being exploited?

There is no known exploitation of CVE-2026-46708 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46708 and fix it if it is affected.

What it is: CVE-2026-46708 is a medium-severity missing authorization vulnerability in espocrm, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46708 in the wild and no public exploit code.

Affected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46708/ (Markdown: https://insights.sbomify.com/CVE-2026-46708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46708
- OSV: https://osv.dev/vulnerability/CVE-2026-46708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46708/
Summaries are generated and may contain mistakes; the official description above is the record.
