{"answers":{"affected":"2 open source packages ship an affected version, including justhtml.","exploited":"There is no known exploitation of CVE-2026-4671 in the wild and no public exploit code.","fix":"Upgrade justhtml to 1.18.0 or later.","what":"CVE-2026-4671 is a high-severity denial of service vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-4671 and fix it if it is affected.\n\nWhat it is: CVE-2026-4671 is a high-severity denial of service vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-4671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- justhtml (PyPI): affected all versions; fixed in 1.18.0\n- justhtml (PyPI): affected all versions; fixed in 1.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-4671/ (Markdown: https://insights.sbomify.com/CVE-2026-4671/index.md)","id":"CVE-2026-4671","markdown":"https://insights.sbomify.com/CVE-2026-4671/index.md","name":"CVE-2026-4671","record":{"aliases":["GHSA-hm7q-2p3r-88q4","GHSA-r8cj-3554-33mr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"HTML parsing library","requires_auth":"none","summary":"An attacker can cause excessive CPU or memory consumption in justhtml by providing malicious CSS selectors or linkification inputs, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"justhtml before 1.18.0 contains multiple low-severity denial-of-service issues in CSS selector handling and linkification. Applications that evaluate attacker-controlled selector strings (via query(), matches(), or selector-based transforms), run selector matching over very large untrusted documents, construct DOM trees from untrusted structure, or enable linkification over attacker-controlled text may consume disproportionate CPU or memory. Triggers include oversized selectors, large selector lists, oversized compound selectors, long combinator chains, deeply nested functional pseudo-classes, repeated token/positional matching, cyclic DOM graphs causing non-terminating traversal, and punctuation-heavy or trailing-bracket linkification input. These are availability-only concerns and do not by themselves allow script execution, data disclosure, or sanitizer bypass. Default JustHTML(sanitize=True) usage is not expected to be exposed, since selectors are normally supplied by application code.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"justhtml before 1.18.0 Denial of Service via CSS Selector","id":"CVE-2026-4671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Missing Authorization in GitLab","id":"CVE-2026-4672"},"packages":[{"ecosystem":"PyPI","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"justhtml","purl":null,"source":"GHSA-r8cj-3554-33mr"},{"ecosystem":"PyPI","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"justhtml","purl":"pkg:pypi/justhtml","source":"GHSA-r8cj-3554-33mr"}],"prev":{"headline":"Improper Authentication vulnerability in Progress MOVEit Automation","id":"CVE-2026-4670"},"products":["justhtml"],"published":"2026-08-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["EmilStenstrom"]},"summary":"An attacker can cause excessive CPU or memory consumption in justhtml by providing malicious CSS selectors or linkification inputs, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-4671/"}