# CVE-2026-46713: Misskey: JSON-LD signature validation + compaction may lead to improper activity handling

> Attackers can spoof activities as valid due to flawed JSON-LD signature validation, bypassing security checks in Misskey.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** GHSA-w8x2-gpq6-jxvf

## What is CVE-2026-46713?

CVE-2026-46713 is a critical vulnerability in misskey-dev misskey, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Misskey is an open source, federated social media platform. Versions 12.37.0 and later, but prior to 2026.5.4, contain a vulnerability in the JSON-LD signature validation and compaction process that allows spoofed activities to be accepted as valid. This issue has been fixed in version 2026.5.4.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-46713?


## How do I fix CVE-2026-46713?

No fix has been published for CVE-2026-46713 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46713 being exploited?

There is no known exploitation of CVE-2026-46713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46713 and fix it if it is affected.

What it is: CVE-2026-46713 is a critical vulnerability in misskey-dev misskey, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46713 in the wild and no public exploit code.

Affected product: misskey-dev misskey. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46713/ (Markdown: https://insights.sbomify.com/CVE-2026-46713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46713
- OSV: https://osv.dev/vulnerability/CVE-2026-46713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46713/
Summaries are generated and may contain mistakes; the official description above is the record.
