# CVE-2026-46714: Misskey: Denial of Service via Uncontrolled Recursion in Theme Compilation

> An attacker can cause the Misskey web client to crash or slow down by applying a malformed theme, requiring an upgrade to fix.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 3 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-wmhf-m93m-rgmj

## What is CVE-2026-46714?

CVE-2026-46714 is a medium-severity denial of service vulnerability in misskey-dev misskey, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Misskey is an open source, federated social media platform. IVersions 8.63.0 and later, but prior to 2026.5.4, contain a vulnerability that can cause the Misskey web client to slow down or crash when it applies a malformed theme. This issue has been fixed in version 2026.5.4.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-46714?


## How do I fix CVE-2026-46714?

No fix has been published for CVE-2026-46714 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46714 being exploited?

There is no known exploitation of CVE-2026-46714 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46714 and fix it if it is affected.

What it is: CVE-2026-46714 is a medium-severity denial of service vulnerability in misskey-dev misskey, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46714 in the wild and no public exploit code.

Affected product: misskey-dev misskey. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46714/ (Markdown: https://insights.sbomify.com/CVE-2026-46714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46714
- OSV: https://osv.dev/vulnerability/CVE-2026-46714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46714/
Summaries are generated and may contain mistakes; the official description above is the record.
