# CVE-2026-46715: Flask-Security-Too OAuth reauthentication freshness bypass via cross- user OAuth identity acceptance

> Attackers can bypass reauthentication checks by linking their OAuth identity to a victim's stale session, enabling unauthorized account actions.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-97r5-pg8x-p63p, PYSEC-2026-2478

## What is CVE-2026-46715?

CVE-2026-46715 is a medium-severity authentication bypass vulnerability in pallets-eco Flask-Security-Too, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flask-Security-Too allows users to add security features to their Flask applicationa. Version 5.8.0's OAuth reauthentication flow can mark a session as fresh after verifying an OAuth account that belongs to a different user. If an attacker can operate an already-authenticated but stale victim session, they can complete OAuth verification using their own OAuth identity. The victim session is then treated as recently reauthenticated, allowing freshness-protected account actions to proceed. Version 5.8.1 contains a fix for this issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-46715?

3 open source packages ship an affected version, including flask-security-too and Flask-Security-Too.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-security-too` | PyPI | From 5.8.0 | 5.8.1 |
| `flask-security-too` | PyPI | From 5.8.0 | 5.8.1 |
| `Flask-Security-Too` | PyPI | From 5.8.0 | 5.8.1 |

## How do I fix CVE-2026-46715?

Upgrade flask-security-too to 5.8.1 or later.

## Is CVE-2026-46715 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46715 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46715 and fix it if it is affected.

What it is: CVE-2026-46715 is a medium-severity authentication bypass vulnerability in pallets-eco Flask-Security-Too, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46715 exists.

Affected packages and fixed versions:
- flask-security-too (PyPI): affected from 5.8.0; fixed in 5.8.1
- flask-security-too (PyPI): affected from 5.8.0; fixed in 5.8.1
- Flask-Security-Too (PyPI): affected from 5.8.0; fixed in 5.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46715/ (Markdown: https://insights.sbomify.com/CVE-2026-46715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46715
- OSV: https://osv.dev/vulnerability/CVE-2026-46715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46715/
Summaries are generated and may contain mistakes; the official description above is the record.
