# CVE-2026-46717: Nezha Monitoring: RoleMember-reachable SSRF with full response-body reflection via POST /api/v1/notification

> A RoleMember user can trigger Server-Side Request Forgery via notification endpoints, reading internal network responses due to missing authorization checks.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 13 Jun 2026
- **Also known as:** GHSA-w4g9-mxgg-j532, GO-2026-5687

## What is CVE-2026-46717?

CVE-2026-46717 is a high-severity server-side request forgery vulnerability in nezhahq nezha, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nezha Monitoring is a self-hostable, lightweight, servers and websites monitoring and O&M tool. From version 1.4.0 to before version 2.0.8, nezha's dashboard supports two user roles: RoleAdmin (Role==0) and RoleMember (Role==1). The notification routes POST /api/v1/notification and PATCH /api/v1/notification/:id are wired through commonHandler rather than adminHandler — so a RoleMember user can call them. These handlers synchronously Send() an HTTP request to a user-controlled URL and reflect the entire response body (no size limit) back to the caller on any non-2xx response. This issue has been patched in version 2.0.8.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-46717?

3 open source packages ship an affected version, including github.com/nezhahq/nezha.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nezhahq/nezha` | Go | From 1.4.0 | 1.14.15-0.20260517022419-d06d539d34c1 |
| `github.com/nezhahq/nezha` | Go | From 1.4.0 | 1.14.15-0.20260517022419-d06d539d34c1 |
| `github.com/nezhahq/nezha` | Go | From 1.4.0 | 1.14.15-0.20260517022419-d06d539d34c1 |

## How do I fix CVE-2026-46717?

Upgrade github.com/nezhahq/nezha to 1.14.15-0.20260517022419-d06d539d34c1 or later.

## Is CVE-2026-46717 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46717 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46717 and fix it if it is affected.

What it is: CVE-2026-46717 is a high-severity server-side request forgery vulnerability in nezhahq nezha, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46717 exists.

Affected packages and fixed versions:
- github.com/nezhahq/nezha (Go): affected from 1.4.0; fixed in 1.14.15-0.20260517022419-d06d539d34c1
- github.com/nezhahq/nezha (Go): affected from 1.4.0; fixed in 1.14.15-0.20260517022419-d06d539d34c1
- github.com/nezhahq/nezha (Go): affected from 1.4.0; fixed in 1.14.15-0.20260517022419-d06d539d34c1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46717/ (Markdown: https://insights.sbomify.com/CVE-2026-46717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46717
- OSV: https://osv.dev/vulnerability/CVE-2026-46717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46717/
Summaries are generated and may contain mistakes; the official description above is the record.
