# CVE-2026-46745: Apache Airflow FAB provider: LDAP Filter Injection in FAB Auth Manager _search_ldap reachable via /auth/token

> Unauthenticated attackers can inject LDAP filters to exfiltrate directory data or bypass authentication in Apache Airflow FAB provider.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 26 May 2026
- **Also known as:** CLEANSTART-2026-GI56034, ECHO-2db4-4278-75a2, GHSA-g283-w6fp-c4fc, MINI-3jp3-pjr8-gr6f, MINI-8mw4-pq6g-h2mr, PYSEC-2026-2366

## What is CVE-2026-46745?

CVE-2026-46745 is a medium-severity vulnerability in Apache Airflow FAB provider, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow FAB Auth Manager contains an LDAP filter injection vulnerability (CWE-90) that allows unauthenticated attackers to exfiltrate directory data or bypass authentication. Upgrade to apache-airflow-providers-fab 3.6.4 or later. If immediate upgrade is not possible, disable LDAP authentication until the provider can be updated.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2026-46745?

3 open source packages ship an affected version, including apache-airflow-providers-fab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-fab` | PyPI | All versions | 3.6.4 |
| `apache-airflow-providers-fab` | PyPI | All versions | 3.6.4 |
| `apache-airflow-providers-fab` | PyPI | All versions | 3.6.4 |

Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2026-46745?

Upgrade apache-airflow-providers-fab to 3.6.4 or later.

## Is CVE-2026-46745 being exploited?

There is no known exploitation of CVE-2026-46745 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow FAB provider

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2024-42447](https://insights.sbomify.com/CVE-2024-42447/): Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow (critical 9.8)
- [CVE-2026-86462](https://insights.sbomify.com/CVE-2026-86462/): Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions (critical 9.1)
- [CVE-2026-75156](https://insights.sbomify.com/CVE-2026-75156/): Auth bypass in Apache Airflow FAB provider (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46745 and fix it if it is affected.

What it is: CVE-2026-46745 is a medium-severity vulnerability in Apache Airflow FAB provider, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46745 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 3.6.4
- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 3.6.4
- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 3.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46745/ (Markdown: https://insights.sbomify.com/CVE-2026-46745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46745
- OSV: https://osv.dev/vulnerability/CVE-2026-46745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46745/
Summaries are generated and may contain mistakes; the official description above is the record.
