# CVE-2026-46764: Apache Airflow: Event Log detail endpoint bypasses DAG-scoped event log permission filter

> Authenticated users can bypass DAG-scoped permissions to read audit logs from other DAGs by enumerating event log IDs.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-airflow-2026-46764, ECHO-b9e9-15f1-bf82, GHSA-qphr-3mvq-v466, MINI-6cxr-7h4w-jm2g, MINI-m5fc-354v-7v8q, PYSEC-2026-2354

## What is CVE-2026-46764?

CVE-2026-46764 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Event Log detail endpoint `GET /api/v2/eventLogs/{event_log_id}` in Apache Airflow fetched audit-log rows directly by numeric ID after only the generic Audit Log permission check, while the collection endpoint `GET /api/v2/eventLogs` applied per-Dag scoping. An authenticated UI/API user with audit-log read permission for one Dag could retrieve audit-log entries for any other Dag by guessing or enumerating the numeric event log ID. Affects deployments that rely on per-Dag audit-log scoping. Users are advised to upgrade to `apache-airflow` 3.2.2 or later.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-46764?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `airflow` | Bitnami | All versions | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-46764?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-46764 being exploited?

There is no known exploitation of CVE-2026-46764 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46764 and fix it if it is affected.

What it is: CVE-2026-46764 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46764 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- airflow (Bitnami): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46764/ (Markdown: https://insights.sbomify.com/CVE-2026-46764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46764
- OSV: https://osv.dev/vulnerability/CVE-2026-46764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46764/
Summaries are generated and may contain mistakes; the official description above is the record.
