CVE-2026-46917 Denial of service in Oracle GraalVM Enterprise Edition
Unauthenticated attackers can cause partial denial of service in Oracle Java SE and GraalVM via TLS network access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-46917?
CVE-2026-46917 is a medium-severity denial of service vulnerability in Oracle Graalvm, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: JSSE). Supported versions that are affected are Oracle Java SE: 11.0.31, 17.0.19, 21.0.11, 25.0.3, 26.0.1; Oracle GraalVM for JDK: 17.0.19 and 21.0.11; Oracle GraalVM Enterprise Edition: 21.3.18. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).
Weakness: CWE-284
Which versions are affected by CVE-2026-46917?
3 open source packages ship an affected version, including java, java-min and jre. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | From 9.0.0 | 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
java-min Bitnami | From 9.0.0 | 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
jre Bitnami | From 9.0.0 | 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
Products include Oracle Graalvm, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.
How do I fix CVE-2026-46917?
Upgrade java to a fixed version for your release line: 11.0.32, 17.0.20, 21.0.12 or 25.0.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-46917 being exploited?
There is no known exploitation of CVE-2026-46917 in the wild and no public exploit code.
Other vulnerabilities in Oracle Graalvm
- CVE-2025-50059 Security feature bypass in Oracle GraalVM Enterprise Edition
- CVE-2021-32803 Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning
- CVE-2021-32804 Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
- CVE-2025-30749 Code injection in Oracle GraalVM Enterprise Edition
- CVE-2025-50106 Code injection in Oracle GraalVM Enterprise Edition
Sources
Also known as BELL-CVE-2026-46917, BIT-java-2026-46917, BIT-java-min-2026-46917, BIT-jre-2026-46917, DEBIAN-CVE-2026-46917, GHSA-x5x7-pvpw-w5hv and 28 more.