# CVE-2026-46917: Denial of service in Oracle GraalVM Enterprise Edition

> Unauthenticated attackers can cause partial denial of service in Oracle Java SE and GraalVM via TLS network access.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 23 Jul 2026
- **Also known as:** BELL-CVE-2026-46917, BIT-java-2026-46917, BIT-java-min-2026-46917, BIT-jre-2026-46917, DEBIAN-CVE-2026-46917, GHSA-x5x7-pvpw-w5hv, MINI-2p8h-h9jw-r6hf, MINI-2qq8-3x6w-693f, MINI-3h3w-9mmx-xjxx, MINI-3rcf-cgfp-w7cp, MINI-3x4j-qrg3-4cc5, MINI-476c-8rp5-9r79, MINI-63rx-q55f-6x8w, MINI-73c4-7j2f-fc46, MINI-7f7r-p2pg-xv63, MINI-843x-m5qq-92qm, MINI-86p8-33p5-hm4m, MINI-9h95-x3gx-9m5h, MINI-c443-g6r9-85c5, MINI-cpxc-j8w5-pqp8, MINI-cwpf-47wg-648v, MINI-f37x-rjf6-w5hq, MINI-ff97-q2rr-7cr8, MINI-gx79-47wm-cqgh, MINI-h76g-69p8-ww2v, MINI-hhvf-xxg4-hcrh, MINI-jm4p-g923-9q95, MINI-q38w-gf9x-mxph, MINI-q6c5-v43q-8wcc, MINI-r59j-w6vv-w48j, MINI-rxcr-pmww-4v2w, MINI-v9m2-995p-rvxq, MINI-vhqp-fhc7-qv86, UBUNTU-CVE-2026-46917

## What is CVE-2026-46917?

CVE-2026-46917 is a medium-severity denial of service vulnerability in Oracle Graalvm, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: JSSE).  Supported versions that are affected are Oracle Java SE: 11.0.31, 17.0.19, 21.0.11, 25.0.3, 26.0.1; Oracle GraalVM for JDK: 17.0.19 and  21.0.11; Oracle GraalVM Enterprise Edition: 21.3.18. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition.  Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Availability impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-46917?

3 open source packages ship an affected version, including java, java-min and jre. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | From 9.0.0 | 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
| `java-min` | Bitnami | From 9.0.0 | 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
| `jre` | Bitnami | From 9.0.0 | 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |

Products: Oracle Graalvm, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.

## How do I fix CVE-2026-46917?

Upgrade java to a fixed version for your release line: 11.0.32, 17.0.20, 21.0.12 or 25.0.4.

## Is CVE-2026-46917 being exploited?

There is no known exploitation of CVE-2026-46917 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Graalvm

- [CVE-2025-50059](https://insights.sbomify.com/CVE-2025-50059/): Security feature bypass in Oracle GraalVM Enterprise Edition (high 8.6)
- [CVE-2021-32803](https://insights.sbomify.com/CVE-2021-32803/): Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning (high 8.2)
- [CVE-2021-32804](https://insights.sbomify.com/CVE-2021-32804/): Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization (high 8.2)
- [CVE-2025-30749](https://insights.sbomify.com/CVE-2025-30749/): Code injection in Oracle GraalVM Enterprise Edition (high 8.1)
- [CVE-2025-50106](https://insights.sbomify.com/CVE-2025-50106/): Code injection in Oracle GraalVM Enterprise Edition (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46917 and fix it if it is affected.

What it is: CVE-2026-46917 is a medium-severity denial of service vulnerability in Oracle Graalvm, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46917 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected from 9.0.0; fixed in 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2
- java-min (Bitnami): affected from 9.0.0; fixed in 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2
- jre (Bitnami): affected from 9.0.0; fixed in 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46917/ (Markdown: https://insights.sbomify.com/CVE-2026-46917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46917
- OSV: https://osv.dev/vulnerability/CVE-2026-46917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46917/
Summaries are generated and may contain mistakes; the official description above is the record.
