CVE-2026-46968 Missing authorization in Oracle Java SE
An unauthenticated attacker can modify or delete critical data in Oracle Java SE via TLS network access, requiring a security patch.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-46968?
CVE-2026-46968 is a medium-severity missing authorization vulnerability in Oracle Graalvm, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in Oracle Java SE (component: JSSE). Supported versions that are affected are Oracle Java SE: 8u491, 8u491-perf, 11.0.31, 17.0.19, 21.0.11, 25.0.3, 26.0.1; Oracle GraalVM for JDK: 17.0.19 and 21.0.11; Oracle GraalVM Enterprise Edition: 21.3.18. Difficult to exploit vulnerability allows unauthenticated attacker with network access via TLS to compromise Oracle Java SE. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Oracle Java SE accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.9 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N).
Weakness: CWE-284
Which versions are affected by CVE-2026-46968?
3 open source packages ship an affected version, including java, java-min and jre. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
java-min Bitnami | All versions | 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
jre Bitnami | All versions | 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
Products include Oracle Graalvm, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.
How do I fix CVE-2026-46968?
Upgrade java to a fixed version for your release line: 1.8.0, 8.0.501, 11.0.32 or 17.0.20.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-46968 being exploited?
There is no known exploitation of CVE-2026-46968 in the wild and no public exploit code.
Other vulnerabilities in Oracle Graalvm
- CVE-2025-50059 Security feature bypass in Oracle GraalVM Enterprise Edition
- CVE-2021-32803 Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning
- CVE-2021-32804 Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
- CVE-2025-30749 Code injection in Oracle GraalVM Enterprise Edition
- CVE-2025-50106 Code injection in Oracle GraalVM Enterprise Edition
Sources
Also known as BELL-CVE-2026-46968, BIT-java-2026-46968, BIT-java-min-2026-46968, BIT-jre-2026-46968, DEBIAN-CVE-2026-46968, GHSA-hhf8-3x8g-6pff and 29 more.