# CVE-2026-47070: HTTP/3 redirect handler leaks Authorization and Cookie headers to cross-origin redirect target in hackney

> Hackney HTTP/3 client leaks Authorization and Cookie headers to cross-origin redirect targets, exposing sensitive credentials to attackers.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 27 May 2026
- **Also known as:** EEF-CVE-2026-47070, GHSA-h73q-4w9q-82h4

## What is CVE-2026-47070?

CVE-2026-47070 is a medium-severity vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Sensitive Data Exposure vulnerability in benoitc hackney allows Retrieve Embedded Sensitive Data. The HTTP/3 redirect handler in src/hackney_h3.erl passes the original request headers unchanged to the redirect target without performing any cross-origin check. When a client issues an HTTP/3 request with follow_redirect enabled and includes Authorization or Cookie headers, a server responding with a 3xx redirect to a different host will cause the client to forward those credentials verbatim to the new origin.

The main hackney.erl module has maybe_strip_auth_on_redirect/2 (guarded by the location_trusted option) to address CVE-2018-1000007, but hackney_h3.erl is missing this protection entirely.

This issue affects hackney: from 3.1.1 before 4.0.1.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-47070?

3 open source packages ship an affected version, including hackney. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 3.1.1 | 4.0.1 |
| `hackney` | Hex | From 3.1.1 | 4.0.1 |
| `hackney` | Hex | From 3.1.1 | 4.0.1 |

Products: Benoitc Hackney.

## How do I fix CVE-2026-47070?

Upgrade hackney to 4.0.1 or later.

## Is CVE-2026-47070 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47070 exists.

## Other vulnerabilities in benoitc hackney

- [CVE-2026-47066](https://insights.sbomify.com/CVE-2026-47066/): Infinite loop in Alt-Svc header parser in hackney (high 8.7)
- [CVE-2026-47067](https://insights.sbomify.com/CVE-2026-47067/): Atom table exhaustion via unrecognized URL schemes in hackney (high 8.7)
- [CVE-2026-47073](https://insights.sbomify.com/CVE-2026-47073/): Unbounded memory consumption in WebSocket client in hackney (high 8.7)
- [CVE-2026-47071](https://insights.sbomify.com/CVE-2026-47071/): SOCKS5 TLS upgrade ignores caller timeout in hackney (high 8.2)
- [CVE-2026-47077](https://insights.sbomify.com/CVE-2026-47077/): Unbounded body accumulation in HTTP/3 response loop in hackney (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47070 and fix it if it is affected.

What it is: CVE-2026-47070 is a medium-severity vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47070 exists.

Affected packages and fixed versions:
- hackney (Hex): affected from 3.1.1; fixed in 4.0.1
- hackney (Hex): affected from 3.1.1; fixed in 4.0.1
- hackney (Hex): affected from 3.1.1; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47070/ (Markdown: https://insights.sbomify.com/CVE-2026-47070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47070
- OSV: https://osv.dev/vulnerability/CVE-2026-47070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47070/
Summaries are generated and may contain mistakes; the official description above is the record.
