# CVE-2026-47071: SOCKS5 TLS upgrade ignores caller timeout in hackney

> A hostile SOCKS5 proxy can cause indefinite blocking in hackney by stalling the TLS handshake, ignoring caller-supplied timeouts.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 27 May 2026
- **Also known as:** EEF-CVE-2026-47071, GHSA-gp9c-pm5m-5cxr

## What is CVE-2026-47071?

CVE-2026-47071 is a high-severity denial of service vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled Resource Consumption vulnerability in benoitc hackney allows Flooding. The SOCKS5 transport in src/hackney_socks5.erl correctly applies the caller-supplied timeout to the SOCKS5 negotiation phase, but then upgrades the connection to TLS using the two-argument form ssl:connect/2, which defaults to an infinite timeout. The Timeout value is in scope at the call site but is not forwarded. A hostile SOCKS5 proxy that completes the SOCKS5 handshake normally and then goes silent (or sends a partial TLS ServerHello and stalls) will cause the connecting process to block indefinitely, regardless of the connect_timeout or recv_timeout options supplied by the caller.

This issue affects hackney: from 0.10.0 before 4.0.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-47071?

3 open source packages ship an affected version, including hackney. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 0.10.0 | 4.0.1 |
| `hackney` | Hex | From 0.10.0 | 4.0.1 |
| `hackney` | Hex | From 0.10.0 | 4.0.1 |

Products: Benoitc Hackney.

## How do I fix CVE-2026-47071?

Upgrade hackney to 4.0.1 or later.

## Is CVE-2026-47071 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47071 exists.

## Other vulnerabilities in benoitc hackney

- [CVE-2026-47066](https://insights.sbomify.com/CVE-2026-47066/): Infinite loop in Alt-Svc header parser in hackney (high 8.7)
- [CVE-2026-47067](https://insights.sbomify.com/CVE-2026-47067/): Atom table exhaustion via unrecognized URL schemes in hackney (high 8.7)
- [CVE-2026-47073](https://insights.sbomify.com/CVE-2026-47073/): Unbounded memory consumption in WebSocket client in hackney (high 8.7)
- [CVE-2026-47077](https://insights.sbomify.com/CVE-2026-47077/): Unbounded body accumulation in HTTP/3 response loop in hackney (high 8.2)
- [CVE-2026-47072](https://insights.sbomify.com/CVE-2026-47072/): CRLF injection in WebSocket upgrade request in hackney (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47071 and fix it if it is affected.

What it is: CVE-2026-47071 is a high-severity denial of service vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47071 exists.

Affected packages and fixed versions:
- hackney (Hex): affected from 0.10.0; fixed in 4.0.1
- hackney (Hex): affected from 0.10.0; fixed in 4.0.1
- hackney (Hex): affected from 0.10.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47071/ (Markdown: https://insights.sbomify.com/CVE-2026-47071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47071
- OSV: https://osv.dev/vulnerability/CVE-2026-47071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47071/
Summaries are generated and may contain mistakes; the official description above is the record.
