# CVE-2026-47072: CRLF injection in WebSocket upgrade request in hackney

> Attackers can inject CRLF sequences into WebSocket upgrade requests via untrusted input, enabling header injection and request smuggling in applications using hackney.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 27 May 2026
- **Also known as:** EEF-CVE-2026-47072, GHSA-f9vr-g2g2-x9fg

## What is CVE-2026-47072?

CVE-2026-47072 is a medium-severity vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of CRLF Sequences ('CRLF Injection') vulnerability in benoitc hackney allows HTTP Request/Response Splitting. The WebSocket upgrade code in src/hackney_ws.erl copies the host, path, headers (ExtraHeaders), and protocols options from the caller-supplied opts map into the internal #ws_data{} record in init/1 and then splices them verbatim into the raw HTTP/1.1 upgrade request by binary concatenation in do_handshake/1. No CRLF or NUL stripping is performed at any of these four injection sites. An attacker who controls any of these options — for example by forwarding URL components or header values from untrusted input into hackney_ws:start_link/1 — can inject arbitrary HTTP headers into the outbound WebSocket upgrade request, leading to header injection, credential spoofing toward the upstream server, log and cache poisoning, or request smuggling via intermediary proxies.

This issue affects hackney: from 2.0.0 before 4.0.1.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-47072?

3 open source packages ship an affected version, including hackney. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 2.0.0 | 4.0.1 |
| `hackney` | Hex | From 2.0.0 | 4.0.1 |
| `hackney` | Hex | From 2.0.0 | 4.0.1 |

Products: Benoitc Hackney.

## How do I fix CVE-2026-47072?

Upgrade hackney to 4.0.1 or later.

## Is CVE-2026-47072 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47072 exists.

## Other vulnerabilities in benoitc hackney

- [CVE-2026-47066](https://insights.sbomify.com/CVE-2026-47066/): Infinite loop in Alt-Svc header parser in hackney (high 8.7)
- [CVE-2026-47067](https://insights.sbomify.com/CVE-2026-47067/): Atom table exhaustion via unrecognized URL schemes in hackney (high 8.7)
- [CVE-2026-47073](https://insights.sbomify.com/CVE-2026-47073/): Unbounded memory consumption in WebSocket client in hackney (high 8.7)
- [CVE-2026-47071](https://insights.sbomify.com/CVE-2026-47071/): SOCKS5 TLS upgrade ignores caller timeout in hackney (high 8.2)
- [CVE-2026-47077](https://insights.sbomify.com/CVE-2026-47077/): Unbounded body accumulation in HTTP/3 response loop in hackney (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47072 and fix it if it is affected.

What it is: CVE-2026-47072 is a medium-severity vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47072 exists.

Affected packages and fixed versions:
- hackney (Hex): affected from 2.0.0; fixed in 4.0.1
- hackney (Hex): affected from 2.0.0; fixed in 4.0.1
- hackney (Hex): affected from 2.0.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47072/ (Markdown: https://insights.sbomify.com/CVE-2026-47072/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47072
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47072
- OSV: https://osv.dev/vulnerability/CVE-2026-47072

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47072/
Summaries are generated and may contain mistakes; the official description above is the record.
