# CVE-2026-47073: Unbounded memory consumption in WebSocket client in hackney

> A malicious WebSocket server can cause unbounded memory consumption in the hackney client, leading to denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 27 May 2026
- **Also known as:** EEF-CVE-2026-47073, GHSA-q8jg-fgj4-fphf

## What is CVE-2026-47073?

CVE-2026-47073 is a high-severity denial of service vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in benoitc hackney allows Flooding. The WebSocket client in src/hackney_ws.erl imposes no upper bound on memory consumption in three code paths. First, read_handshake_response/3 accumulates received bytes into a growing buffer with no size cap; the per-receive timeout resets on every chunk, so a server that streams bytes without ever sending \r\n\r\n causes the buffer to grow until memory is exhausted. Second, parse_payload/9 and parse_active_payload/8 do not validate the declared frame payload length against any limit; because RFC 6455 allows payload lengths up to 2^63-1 bytes, a server that announces a very large frame and dribbles bytes causes the accumulation buffer to grow until OOM. Third, the frag_buffer field in #ws_data{} accumulates continuation frames indefinitely; a server that sends an endless stream of non-final (nofin) fragmented frames without ever sending a final (fin) frame grows frag_buffer without bound.

In all three cases the attacker only needs to control the WebSocket server the hackney client connects to, with no authentication or special client configuration required.

This issue affects hackney: from 2.0.0 before 4.0.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-47073?

3 open source packages ship an affected version, including hackney. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 2.0.0 | 4.0.1 |
| `hackney` | Hex | From 2.0.0 | 4.0.1 |
| `hackney` | Hex | From 2.0.0 | 4.0.1 |

Products: Benoitc Hackney.

## How do I fix CVE-2026-47073?

Upgrade hackney to 4.0.1 or later.

## Is CVE-2026-47073 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47073 exists.

## Other vulnerabilities in benoitc hackney

- [CVE-2026-47066](https://insights.sbomify.com/CVE-2026-47066/): Infinite loop in Alt-Svc header parser in hackney (high 8.7)
- [CVE-2026-47067](https://insights.sbomify.com/CVE-2026-47067/): Atom table exhaustion via unrecognized URL schemes in hackney (high 8.7)
- [CVE-2026-47071](https://insights.sbomify.com/CVE-2026-47071/): SOCKS5 TLS upgrade ignores caller timeout in hackney (high 8.2)
- [CVE-2026-47077](https://insights.sbomify.com/CVE-2026-47077/): Unbounded body accumulation in HTTP/3 response loop in hackney (high 8.2)
- [CVE-2026-47072](https://insights.sbomify.com/CVE-2026-47072/): CRLF injection in WebSocket upgrade request in hackney (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47073 and fix it if it is affected.

What it is: CVE-2026-47073 is a high-severity denial of service vulnerability in benoitc hackney, published on 25 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47073 exists.

Affected packages and fixed versions:
- hackney (Hex): affected from 2.0.0; fixed in 4.0.1
- hackney (Hex): affected from 2.0.0; fixed in 4.0.1
- hackney (Hex): affected from 2.0.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47073/ (Markdown: https://insights.sbomify.com/CVE-2026-47073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47073
- OSV: https://osv.dev/vulnerability/CVE-2026-47073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47073/
Summaries are generated and may contain mistakes; the official description above is the record.
