# CVE-2026-47075: CR/LF injection in query parameter in hackney

> Attackers can inject CRLF sequences into URLs to split HTTP requests or inject headers, affecting applications using the hackney library.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 24 Jul 2026
- **Also known as:** EEF-CVE-2026-47075, GHSA-j9wq-vxxc-94wf

## What is CVE-2026-47075?

CVE-2026-47075 is a medium-severity vulnerability in benoitc hackney, published on 25 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of CRLF Sequences vulnerability in benoitc hackney allows HTTP Request Splitting. hackney does not percent-encode carriage return (\r) or line feed (\n) characters in the URL query component before constructing the HTTP/1.1 request target. Characters outside the grammar defined in RFC 3986 Section 3.4 must be percent-encoded, but hackney_url:make_url/3 passes the query binary directly without validation or escaping. An attacker who can control all or part of a URL passed to hackney can inject raw CRLF sequences into the query string, which are then sent as HTTP line breaks in the request target. This enables injection of arbitrary HTTP headers or splitting of the HTTP request.

This issue affects hackney: from 0.13.1 before 4.0.1.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-47075?

3 open source packages ship an affected version, including hackney. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | All versions | 4.0.1 |
| `hackney` | Hex | All versions | 4.0.1 |
| `hackney` | Hex | From 0.13.1 | 4.0.1 |

Products: Benoitc Hackney.

## How do I fix CVE-2026-47075?

Upgrade hackney to 4.0.1 or later.

## Is CVE-2026-47075 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47075 exists.

## Other vulnerabilities in benoitc hackney

- [CVE-2026-47066](https://insights.sbomify.com/CVE-2026-47066/): Infinite loop in Alt-Svc header parser in hackney (high 8.7)
- [CVE-2026-47067](https://insights.sbomify.com/CVE-2026-47067/): Atom table exhaustion via unrecognized URL schemes in hackney (high 8.7)
- [CVE-2026-47073](https://insights.sbomify.com/CVE-2026-47073/): Unbounded memory consumption in WebSocket client in hackney (high 8.7)
- [CVE-2026-47071](https://insights.sbomify.com/CVE-2026-47071/): SOCKS5 TLS upgrade ignores caller timeout in hackney (high 8.2)
- [CVE-2026-47077](https://insights.sbomify.com/CVE-2026-47077/): Unbounded body accumulation in HTTP/3 response loop in hackney (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47075 and fix it if it is affected.

What it is: CVE-2026-47075 is a medium-severity vulnerability in benoitc hackney, published on 25 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47075 exists.

Affected packages and fixed versions:
- hackney (Hex): affected all versions; fixed in 4.0.1
- hackney (Hex): affected all versions; fixed in 4.0.1
- hackney (Hex): affected from 0.13.1; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47075/ (Markdown: https://insights.sbomify.com/CVE-2026-47075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47075
- OSV: https://osv.dev/vulnerability/CVE-2026-47075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47075/
Summaries are generated and may contain mistakes; the official description above is the record.
