# CVE-2026-47076: SSRF allowlist bypass via percent-encoded host in hackney

> Attackers can bypass SSRF allowlists in hackney by using percent-encoded hosts, enabling access to internal services and cloud metadata.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 27 May 2026
- **Also known as:** EEF-CVE-2026-47076, GHSA-pj7v-xfvx-wmjq

## What is CVE-2026-47076?

CVE-2026-47076 is a medium-severity server-side request forgery vulnerability in benoitc hackney, published on 25 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Interpretation Conflict vulnerability in benoitc hackney allows Server Side Request Forgery. hackney_url:normalize/2 URL-decodes the host component after the URL has been parsed into a #hackney_url{} record. OTP's uri_string:parse/1 and inet:parse_address/1 do not decode percent-escapes in the host, so a URL such as http://%31%32%37%2E%30%2E%30%2E%31/ is seen by a caller's allowlist validator with host %31%32%37%2E%30%2E%30%2E%31 (not an IP address), which passes the allowlist check. hackney's normalizer then decodes the host to 127.0.0.1 and opens a TCP connection to loopback. Because hackney:request/5 always calls hackney_url:normalize/2 with no opt-out, every request that takes a binary or list URL is affected. The same technique reaches cloud instance metadata services (169.254.169.254), RFC1918 networks, and any admin interface listening on localhost.

This issue affects hackney: from 0.13.0 before 4.0.1.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-47076?

3 open source packages ship an affected version, including hackney. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 0.13.0 | 4.0.1 |
| `hackney` | Hex | From 0.13.0 | 4.0.1 |
| `hackney` | Hex | From 0.13.0 | 4.0.1 |

Products: Benoitc Hackney.

## How do I fix CVE-2026-47076?

Upgrade hackney to 4.0.1 or later.

## Is CVE-2026-47076 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47076 exists.

## Other vulnerabilities in benoitc hackney

- [CVE-2026-47066](https://insights.sbomify.com/CVE-2026-47066/): Infinite loop in Alt-Svc header parser in hackney (high 8.7)
- [CVE-2026-47067](https://insights.sbomify.com/CVE-2026-47067/): Atom table exhaustion via unrecognized URL schemes in hackney (high 8.7)
- [CVE-2026-47073](https://insights.sbomify.com/CVE-2026-47073/): Unbounded memory consumption in WebSocket client in hackney (high 8.7)
- [CVE-2026-47071](https://insights.sbomify.com/CVE-2026-47071/): SOCKS5 TLS upgrade ignores caller timeout in hackney (high 8.2)
- [CVE-2026-47077](https://insights.sbomify.com/CVE-2026-47077/): Unbounded body accumulation in HTTP/3 response loop in hackney (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47076 and fix it if it is affected.

What it is: CVE-2026-47076 is a medium-severity server-side request forgery vulnerability in benoitc hackney, published on 25 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47076 exists.

Affected packages and fixed versions:
- hackney (Hex): affected from 0.13.0; fixed in 4.0.1
- hackney (Hex): affected from 0.13.0; fixed in 4.0.1
- hackney (Hex): affected from 0.13.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47076/ (Markdown: https://insights.sbomify.com/CVE-2026-47076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47076
- OSV: https://osv.dev/vulnerability/CVE-2026-47076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47076/
Summaries are generated and may contain mistakes; the official description above is the record.
