# CVE-2026-47080: CDATA Section Breakout via Unsanitised ]]> in xml_builder

> Attackers can inject arbitrary XML markup by breaking out of CDATA sections in xml_builder, potentially corrupting downstream XML processing.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** EEF-CVE-2026-47080, GHSA-67r9-hmxw-h595

## What is CVE-2026-47080?

CVE-2026-47080 is a low-severity vulnerability in joshnuss xml_builder, published on 21 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

XML Injection vulnerability in joshnuss xml_builder (XmlBuilder module) allows Content Spoofing, XML Injection.

This vulnerability is associated with program files lib/xml_builder.ex and program routines XmlBuilder.generate/1, XmlBuilder.generate/2, XmlBuilder.escape/1.

The escape/1 clause for {:cdata, data} in lib/xml_builder.ex concatenates data verbatim between the CDATA opener <![CDATA[ and closer ]]> without rewriting or splitting on the embedded ]]> sequence. Because CDATA sections have no internal escape mechanism, the only safe way to embed arbitrary bytes is to split on ]]> and emit adjacent CDATA sections. An attacker who can supply input containing ]]> closes the CDATA section early; any bytes that follow are parsed as ordinary XML markup by downstream consumers, allowing injection of arbitrary elements, text, or entity references into the output document.

This issue affects xml_builder: from 0.0.7 before 2.4.1.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2026-47080?

1 open source package ship an affected version, including xml_builder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xml_builder` | Hex | From 0.0.7 | 2.4.1 |

## How do I fix CVE-2026-47080?

Upgrade xml_builder to 2.4.1 or later.

## Is CVE-2026-47080 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47080 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47080 and fix it if it is affected.

What it is: CVE-2026-47080 is a low-severity vulnerability in joshnuss xml_builder, published on 21 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47080 exists.

Affected packages and fixed versions:
- xml_builder (Hex): affected from 0.0.7; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47080/ (Markdown: https://insights.sbomify.com/CVE-2026-47080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47080
- OSV: https://osv.dev/vulnerability/CVE-2026-47080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47080/
Summaries are generated and may contain mistakes; the official description above is the record.
