{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47101 exists.","fix":"Upgrade litellm to 1.83.14 or later.","what":"CVE-2026-47101 is a high-severity vulnerability in BerriAI litellm, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-47101 and fix it if it is affected.\n\nWhat it is: CVE-2026-47101 is a high-severity vulnerability in BerriAI litellm, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47101 exists.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.83.14\n- litellm (PyPI): affected all versions; fixed in 1.83.14\n- litellm (PyPI): affected all versions; fixed in 1.83.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47101/ (Markdown: https://insights.sbomify.com/CVE-2026-47101/index.md)","id":"CVE-2026-47101","markdown":"https://insights.sbomify.com/CVE-2026-47101/index.md","name":"CVE-2026-47101","record":{"aliases":["ECHO-dcda-3b71-8055","GHSA-qrc4-49gv-mv9m","MINI-5rp6-jvrv-h46r","MINI-cch3-gg7h-5w52","MINI-crr3-ccw6-5gx2","MINI-jfpw-87hx-637c","MINI-wggj-hvh3-7856","MINI-wp34-gx5g-4g6r","PYSEC-2026-2598"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM Python library","requires_auth":"low_privilege","summary":"Authenticated internal users can escalate privileges to proxy_admin by generating API keys with unauthorized admin-only routes.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"LiteLLM prior to 1.83.14 allows an authenticated internal_user to create API keys with access to routes that their role does not permit. When generating a key, the allowed_routes field is stored without verifying that the specified routes fall within the user's own permissions. A key created with access to admin-only routes can then be used to reach those routes successfully, bypassing the role-based access controls that would otherwise block the request, enabling full privilege escalation from internal_user to proxy_admin.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-05-25","github_poc":2,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-25T09:10:39Z","kind":"github_poc","ref":"https://github.com/learner202649/CVE-2026-47101-PoC","stars":0,"title":"The code for personally reproducing the corresponding vulnerability"},{"date":"2026-06-16T01:23:37Z","kind":"github_poc","ref":"https://github.com/HORKimhab/CVE-LiteLLM","stars":0,"title":"CVE-2026-47101, CVE-2026-47102,  CVE-2026-40217"}],"tier":"weaponised"},"has_fix":true,"headline":"LiteLLM \u003c 1.83.14 Privilege Escalation via API Key Generation","id":"CVE-2026-47101","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":3,"n_references":8,"next":{"headline":"LiteLLM \u003c 1.83.10 Privilege Escalation via User Update","id":"CVE-2026-47102"},"packages":[{"ecosystem":"PyPI","fixed":["1.83.14"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-qrc4-49gv-mv9m"},{"ecosystem":"PyPI","fixed":["1.83.14"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-qrc4-49gv-mv9m"},{"ecosystem":"PyPI","fixed":["1.83.14"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-2598"}],"prev":{"headline":"Funnel Builder for WooCommerce Checkout \u003c 3.15.0.3 Missing Authorization via AJAX","id":"CVE-2026-47100"},"products":["litellm"],"published":"2026-05-21","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.8,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","kev_date_added":"2026-09-02","published":"2026-07-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","kev_date_added":null,"published":"2024-04-10"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["BerriAI"]},"summary":"Authenticated internal users can escalate privileges to proxy_admin by generating API keys with unauthorized admin-only routes.","url":"https://insights.sbomify.com/CVE-2026-47101/"}