# CVE-2026-47101: LiteLLM < 1.83.14 Privilege Escalation via API Key Generation

> Authenticated internal users can escalate privileges to proxy_admin by generating API keys with unauthorized admin-only routes.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 8 Oct 2026
- **Also known as:** ECHO-dcda-3b71-8055, GHSA-qrc4-49gv-mv9m, MINI-5rp6-jvrv-h46r, MINI-cch3-gg7h-5w52, MINI-crr3-ccw6-5gx2, MINI-jfpw-87hx-637c, MINI-wggj-hvh3-7856, MINI-wp34-gx5g-4g6r, PYSEC-2026-2598

## What is CVE-2026-47101?

CVE-2026-47101 is a high-severity vulnerability in BerriAI litellm, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM prior to 1.83.14 allows an authenticated internal_user to create API keys with access to routes that their role does not permit. When generating a key, the allowed_routes field is stored without verifying that the specified routes fall within the user's own permissions. A key created with access to admin-only routes can then be used to reach those routes successfully, bypassing the role-based access controls that would otherwise block the request, enabling full privilege escalation from internal_user to proxy_admin.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-47101?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.83.14 |
| `litellm` | PyPI | All versions | 1.83.14 |
| `litellm` | PyPI | All versions | 1.83.14 |

Products: Litellm Litellm.

## How do I fix CVE-2026-47101?

Upgrade litellm to 1.83.14 or later.

## Is CVE-2026-47101 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47101 exists.

Public exploit code:

- The code for personally reproducing the corresponding vulnerability (github_poc): https://github.com/learner202649/CVE-2026-47101-PoC
- CVE-2026-47101, CVE-2026-47102,  CVE-2026-40217 (github_poc): https://github.com/HORKimhab/CVE-LiteLLM

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47101 and fix it if it is affected.

What it is: CVE-2026-47101 is a high-severity vulnerability in BerriAI litellm, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47101 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.83.14
- litellm (PyPI): affected all versions; fixed in 1.83.14
- litellm (PyPI): affected all versions; fixed in 1.83.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47101/ (Markdown: https://insights.sbomify.com/CVE-2026-47101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47101
- OSV: https://osv.dev/vulnerability/CVE-2026-47101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47101/
Summaries are generated and may contain mistakes; the official description above is the record.
