# CVE-2026-47102: LiteLLM < 1.83.10 Privilege Escalation via User Update

> A user can escalate privileges to proxy_admin by modifying their own role via the user update endpoint, gaining full administrative access.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 8 Oct 2026
- **Also known as:** ECHO-91ac-5d81-2d88, GHSA-wpfp-gwwc-vwq6, MINI-2277-q6v6-mwhq, MINI-4cfc-58gp-fv6r, MINI-7c24-cx5c-47cm, MINI-968x-6mmc-fg2f, MINI-fqxc-rvm9-q4g6, MINI-fr84-wxcr-xvxr, PYSEC-2026-2600

## What is CVE-2026-47102?

CVE-2026-47102 is a high-severity vulnerability in BerriAI litellm, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM prior to 1.83.10 allows a user to modify their own user_role via the /user/update endpoint. While the endpoint correctly restricts users to updating only their own account, it does not restrict which fields may be changed. A user who can reach this endpoint can set their role to proxy_admin, gaining full administrative access to LiteLLM including all users, teams, keys, models, and prompt history. Users with the org_admin role have legitimate access to this endpoint and can exploit this vulnerability without chaining any additional flaw.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-47102?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.83.10 |
| `litellm` | PyPI | All versions | 1.83.10 |
| `litellm` | PyPI | All versions | 1.83.10 |

Products: Litellm Litellm.

## How do I fix CVE-2026-47102?

Upgrade litellm to 1.83.10 or later.

## Is CVE-2026-47102 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47102 exists.

Public exploit code:

- The code for personally reproducing the corresponding vulnerability (github_poc): https://github.com/learner202649/CVE-2026-47102-PoC

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47102 and fix it if it is affected.

What it is: CVE-2026-47102 is a high-severity vulnerability in BerriAI litellm, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47102 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.83.10
- litellm (PyPI): affected all versions; fixed in 1.83.10
- litellm (PyPI): affected all versions; fixed in 1.83.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47102/ (Markdown: https://insights.sbomify.com/CVE-2026-47102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47102
- OSV: https://osv.dev/vulnerability/CVE-2026-47102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47102/
Summaries are generated and may contain mistakes; the official description above is the record.
