# CVE-2026-47104: libusb < 1.0.30 Out-of-Bounds Read in parse_iad_array()

> Attackers can cause a denial of service in applications using libusb by supplying malformed USB descriptors that trigger an out-of-bounds read.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 14 Jul 2026
- **Also known as:** AZL-88409, AZL-89156, BELL-CVE-2026-47104, DEBIAN-CVE-2026-47104, ECHO-a3a1-40f9-fc5f, GHSA-fh6g-r8pf-wqgw, JLSEC-2026-666, MINI-fg8v-hvj7-8fgp, PYSEC-2026-3979

## What is CVE-2026-47104?

CVE-2026-47104 is a medium-severity memory corruption vulnerability in libusb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libusb before version 1.0.30 contains a one-byte out-of-bounds read vulnerability in parse_iad_array() in descriptor.c that allows attackers to trigger a denial of service by supplying a malformed USB descriptor whose bLength equals size minus one, causing the bounds check to use the original buffer size instead of the remaining size. Attackers in virtualized environments with USB passthrough can supply crafted descriptors through libusb_get_active_interface_association_descriptors or libusb_get_interface_association_descriptors to read one byte past the end of the malloc allocation, resulting in a denial of service.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-47104?

1 open source package ship an affected version, including libusb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libusb` | PyPI | All versions | 1.0.30 |

Products: Libusb Libusb.

## How do I fix CVE-2026-47104?

Upgrade libusb to 1.0.30 or later.

## Is CVE-2026-47104 being exploited?

There is no known exploitation of CVE-2026-47104 in the wild and no public exploit code.

## Other vulnerabilities in libusb

- [CVE-2026-23679](https://insights.sbomify.com/CVE-2026-23679/): libusb < 1.0.30 NULL Pointer Dereference in parse_interface() (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47104 and fix it if it is affected.

What it is: CVE-2026-47104 is a medium-severity memory corruption vulnerability in libusb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47104 in the wild and no public exploit code.

Affected packages and fixed versions:
- libusb (PyPI): affected all versions; fixed in 1.0.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47104/ (Markdown: https://insights.sbomify.com/CVE-2026-47104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47104
- OSV: https://osv.dev/vulnerability/CVE-2026-47104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47104/
Summaries are generated and may contain mistakes; the official description above is the record.
