# CVE-2026-47110: Tiptap for PHP < 2.1.1 DoS via Malformed href Attribute

> Authenticated attackers can crash the server-side HTML rendering pipeline by submitting malformed JSON with an array in the href attribute.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-4595-7fjw-r3jh

## What is CVE-2026-47110?

CVE-2026-47110 is a high-severity denial of service vulnerability in ueberdosis tiptap-php, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Tiptap for PHP before version 2.1.1 contains an input validation vulnerability that allows authenticated attackers to cause a denial of service by submitting Tiptap JSON with the attrs.href field set to an array instead of a string, causing an unhandled TypeError in the Link::isAllowedUri() function when passed to preg_match(). Attackers can persist malformed JSON records that permanently crash the server-side HTML rendering pipeline for all subsequent viewers of that record until the database entry is manually repaired.

Weakness: CWE-241 (Improper Handling of Unexpected Data Type)

## Which versions are affected by CVE-2026-47110?

2 open source packages ship an affected version, including ueberdosis/tiptap-php.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ueberdosis/tiptap-php` | Packagist | All versions | 2.1.1 |
| `ueberdosis/tiptap-php` | Packagist | All versions | 2.1.1 |

## How do I fix CVE-2026-47110?

Upgrade ueberdosis/tiptap-php to 2.1.1 or later.

## Is CVE-2026-47110 being exploited?

There is no known exploitation of CVE-2026-47110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47110 and fix it if it is affected.

What it is: CVE-2026-47110 is a high-severity denial of service vulnerability in ueberdosis tiptap-php, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47110 in the wild and no public exploit code.

Affected packages and fixed versions:
- ueberdosis/tiptap-php (Packagist): affected all versions; fixed in 2.1.1
- ueberdosis/tiptap-php (Packagist): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47110/ (Markdown: https://insights.sbomify.com/CVE-2026-47110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47110
- OSV: https://osv.dev/vulnerability/CVE-2026-47110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47110/
Summaries are generated and may contain mistakes; the official description above is the record.
