{"answers":{"affected":"3 open source packages ship an affected version, including openmed.","exploited":"There is no known exploitation of CVE-2026-47117 in the wild and no public exploit code.","fix":"Upgrade openmed to 1.5.2 or later.","what":"CVE-2026-47117 is a critical code injection vulnerability in maziyarpanahi openmed, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-47117 and fix it if it is affected.\n\nWhat it is: CVE-2026-47117 is a critical code injection vulnerability in maziyarpanahi openmed, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-47117 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openmed (PyPI): affected all versions; fixed in 1.5.2\n- openmed (PyPI): affected all versions; fixed in 1.5.2\n- openmed (PyPI): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47117/ (Markdown: https://insights.sbomify.com/CVE-2026-47117/index.md)","id":"CVE-2026-47117","markdown":"https://insights.sbomify.com/CVE-2026-47117/index.md","name":"CVE-2026-47117","record":{"aliases":["GHSA-m3v4-v5gx-7wf5","PYSEC-2026-2852"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenMed medical library","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary code by supplying a malicious model name that triggers remote code execution during model loading.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"OpenMed before 1.5.2 contains a remote code execution vulnerability in the PII privacy-filter model loading path. The privacy-filter dispatcher used broad substring matching on the user-supplied model_name parameter, allowing a value such as attacker/foo-privacy-filter-bar to route through a path that loads Hugging Face models with trust_remote_code=True. An unauthenticated attacker can supply a malicious model repository containing custom Transformers code via auto_map in config.json or tokenizer_config.json, which is imported and executed with the privileges of the OpenMed service process.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-08-15","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-08-15T20:23:48Z","kind":"github_poc","ref":"https://github.com/SaiTeja-Erukude/CVE-2026-47117-openmed-rce","stars":0,"title":"OpenMed \u003c 1.5.2 unauthenticated RCE via PII privacy-filter model loading and trust_remote_code=True"}],"tier":"poc_unverified"},"has_fix":true,"headline":"OpenMed \u003c 1.5.2 Remote Code Execution via PII Model Loading","id":"CVE-2026-47117","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":5,"next":{"headline":"Agent Zero \u003c 1.15 Path Traversal File Read via image_get API","id":"CVE-2026-47118"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"openmed","purl":null,"source":"GHSA-m3v4-v5gx-7wf5"},{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"openmed","purl":"pkg:pypi/openmed","source":"GHSA-m3v4-v5gx-7wf5"},{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"openmed","purl":"pkg:pypi/openmed","source":"PYSEC-2026-2852"}],"prev":{"headline":"LTSecurity LTK3500SF Hard-coded Credentials via Telnet/SSH","id":"CVE-2026-47116"},"products":["openmed"],"published":"2026-06-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["maziyarpanahi"]},"summary":"Unauthenticated attackers can execute arbitrary code by supplying a malicious model name that triggers remote code execution during model loading.","url":"https://insights.sbomify.com/CVE-2026-47117/"}