# CVE-2026-47128: nono: Sandbox escape on Linux via D-Bus: `systemd-run --user`

> Attackers can escape the nono sandbox by accessing local D-Bus sockets, enabling code execution and privilege escalation on Linux systems.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-27vp-2mmc-vmh3

## What is CVE-2026-47128?

CVE-2026-47128 is a medium-severity vulnerability in always-further nono, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

nono is software that allows users to run AI agents in a zero-latency sandbox. Prior to version 0.55.0, the nono Landlock/seccomp policies allow access to local Unix domain sockets (concrete and abstract). This allows an easy sandbox escape by talking to the per-user systemd dbus socket. Version 0.55.0 patches the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-47128?

2 open source packages ship an affected version, including nono-cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nono-cli` | crates.io | All versions | 0.55.0 |
| `nono-cli` | crates.io | All versions | 0.55.0 |

## How do I fix CVE-2026-47128?

Upgrade nono-cli to 0.55.0 or later.

## Is CVE-2026-47128 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47128 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47128 and fix it if it is affected.

What it is: CVE-2026-47128 is a medium-severity vulnerability in always-further nono, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47128 exists.

Affected packages and fixed versions:
- nono-cli (crates.io): affected all versions; fixed in 0.55.0
- nono-cli (crates.io): affected all versions; fixed in 0.55.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47128/ (Markdown: https://insights.sbomify.com/CVE-2026-47128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47128
- OSV: https://osv.dev/vulnerability/CVE-2026-47128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47128/
Summaries are generated and may contain mistakes; the official description above is the record.
