# CVE-2026-47132: phpMyFAQ: SQL LIKE Wildcard Injection in Chat User Search Allows Authenticated User Enumeration

> Authenticated users can enumerate active users via SQL LIKE wildcard injection in the chat search feature of phpMyFAQ.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-6pvm-2vjj-rx4w

## What is CVE-2026-47132?

CVE-2026-47132 is a medium-severity SQL injection vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application. Prior to version 4.2.0-alpha, an authenticated SQL LIKE wildcard injection vulnerability in phpMyFAQ’s chat user search allows any logged-in user to bypass the intended display-name search  filter and enumerate active users. The endpoint escapes SQL string syntax but does not escape `%` and `_`, which remain active `LIKE` wildcards. Version 4.2.0-alpha patches the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-47132?

2 open source packages ship an affected version, including thorsten/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.2.0-alpha |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.2.0-alpha |

## How do I fix CVE-2026-47132?

Upgrade thorsten/phpmyfaq to 4.2.0-alpha or later.

## Is CVE-2026-47132 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47132 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47132 and fix it if it is affected.

What it is: CVE-2026-47132 is a medium-severity SQL injection vulnerability in thorsten phpMyFAQ, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47132 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.2.0-alpha

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47132/ (Markdown: https://insights.sbomify.com/CVE-2026-47132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47132
- OSV: https://osv.dev/vulnerability/CVE-2026-47132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47132/
Summaries are generated and may contain mistakes; the official description above is the record.
