# CVE-2026-47135: vm2: Sandbox escape via unblocked cross-realm Symbol.for keys + missing bridge write-trap symbol checks

> Attackers can escape the vm2 sandbox to execute arbitrary code on the host by exploiting unblocked cross-realm symbols.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 13 Jun 2026
- **Also known as:** ECHO-3377-7de8-77cf, GHSA-m5q2-4fm3-vfqp, MINI-9q29-2736-7qp5, ROOT-APP-NPM-CVE-2026-47135

## What is CVE-2026-47135?

CVE-2026-47135 is a high-severity code injection vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, Symbol.for override in setup-sandbox.js only intercepts 2 of 9 dangerous Node.js cross-realm symbols. Combined with the bridge's set/defineProperty/deleteProperty traps having no isDangerousCrossRealmSymbol key check, sandbox code can obtain real cross-realm symbols, write them to host objects, and control host-side behavior — verified with a full util.promisify hijack chain. This issue has been patched in version 3.11.4.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-47135?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.4 |
| `vm2` | npm | All versions | 3.11.4 |

## How do I fix CVE-2026-47135?

Upgrade vm2 to 3.11.4 or later.

## Is CVE-2026-47135 being exploited?

There is no known exploitation of CVE-2026-47135 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47135 and fix it if it is affected.

What it is: CVE-2026-47135 is a high-severity code injection vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47135 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.4
- vm2 (npm): affected all versions; fixed in 3.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47135/ (Markdown: https://insights.sbomify.com/CVE-2026-47135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47135
- OSV: https://osv.dev/vulnerability/CVE-2026-47135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47135/
Summaries are generated and may contain mistakes; the official description above is the record.
