{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47137 exists.","fix":"Upgrade vm2 to 3.11.4 or later.","what":"CVE-2026-47137 is a critical code injection vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-47137 and fix it if it is affected.\n\nWhat it is: CVE-2026-47137 is a critical code injection vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47137 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.4\n- vm2 (npm): affected all versions; fixed in 3.11.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47137/ (Markdown: https://insights.sbomify.com/CVE-2026-47137/index.md)","id":"CVE-2026-47137","markdown":"https://insights.sbomify.com/CVE-2026-47137/index.md","name":"CVE-2026-47137","record":{"aliases":["ECHO-a812-7996-036d","GHSA-m4wx-m65x-ghrr","MINI-9574-ffq3-c7x8","ROOT-APP-NPM-CVE-2026-47137"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"none","summary":"Attackers can achieve remote code execution in vm2 by bypassing a security check when nesting is enabled without explicitly disabling require.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-913","name":"Improper Control of Dynamically-Managed Code Resources"}],"description":"vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, the fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. This issue has been patched in version 3.11.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2: GHSA-8hg8-63c5-gwmx patch bypass: nesting:true without explicit require still allows full RCE","id":"CVE-2026-47137","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"Parse Server: Pre-authentication denial of service via client version header regex backtracking","id":"CVE-2026-47138"},"packages":[{"ecosystem":"npm","fixed":["3.11.4"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-m4wx-m65x-ghrr"},{"ecosystem":"npm","fixed":["3.11.4"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-m4wx-m65x-ghrr"}],"prev":{"headline":"RustFS: Unauthenticated RustFS console license endpoint exposes license metadata","id":"CVE-2026-47136"},"products":["vm2"],"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-13","vendors":["patriksimek"]},"summary":"Attackers can achieve remote code execution in vm2 by bypassing a security check when nesting is enabled without explicitly disabling require.","url":"https://insights.sbomify.com/CVE-2026-47137/"}