CVE-2026-47138 Parse Server: Pre-authentication denial of service via client version header regex backtracking
Unauthenticated attackers can cause denial of service in Parse Server by sending crafted HTTP headers that trigger regex backtracking, saturating CPU resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-47138?
CVE-2026-47138 is a high-severity denial of service vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.77 and 9.9.1-alpha.1, an unauthenticated attacker who knows a publicly-known Parse Application ID can submit a single HTTP request whose client SDK version field contains adversarial input that triggers polynomial backtracking in a request-header parser. The parsing runs before session authentication and before rate limiting on every /parse/* request, so the request consumes seconds to minutes of synchronous CPU on a Node.js worker before any access control evaluates it. A small number of concurrent requests can saturate a worker; a single large request via the body-field variant can pin a worker for minutes. Production deployments running the default configuration are affected. This issue has been patched in versions 8.6.77 and 9.9.1-alpha.1.
Weakness: CWE-1333
Which versions are affected by CVE-2026-47138?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.77 |
parse-server npm | All versions | 8.6.77 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.1 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.1 |
parse Bitnami | All versions | 8.6.77, 9.9.1 |
How do I fix CVE-2026-47138?
Upgrade parse-server to a fixed version for your release line: 8.6.77 or 9.9.1-alpha.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-47138 being exploited?
There is no known exploitation of CVE-2026-47138 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2026-47138, GHSA-38m6-82c8-4xfm.