# CVE-2026-47138: Parse Server: Pre-authentication denial of service via client version header regex backtracking

> Unauthenticated attackers can cause denial of service in Parse Server by sending crafted HTTP headers that trigger regex backtracking, saturating CPU resources.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** BIT-parse-2026-47138, GHSA-38m6-82c8-4xfm

## What is CVE-2026-47138?

CVE-2026-47138 is a high-severity denial of service vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.77 and 9.9.1-alpha.1, an unauthenticated attacker who knows a publicly-known Parse Application ID can submit a single HTTP request whose client SDK version field contains adversarial input that triggers polynomial backtracking in a request-header parser. The parsing runs before session authentication and before rate limiting on every /parse/* request, so the request consumes seconds to minutes of synchronous CPU on a Node.js worker before any access control evaluates it. A small number of concurrent requests can saturate a worker; a single large request via the body-field variant can pin a worker for minutes. Production deployments running the default configuration are affected. This issue has been patched in versions 8.6.77 and 9.9.1-alpha.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-47138?

5 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.77 |
| `parse-server` | npm | All versions | 8.6.77 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.1 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.1 |
| `parse` | Bitnami | All versions | 8.6.77, 9.9.1 |

## How do I fix CVE-2026-47138?

Upgrade parse-server to a fixed version for your release line: 8.6.77 or 9.9.1-alpha.1.

## Is CVE-2026-47138 being exploited?

There is no known exploitation of CVE-2026-47138 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47138 and fix it if it is affected.

What it is: CVE-2026-47138 is a high-severity denial of service vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47138 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.77
- parse-server (npm): affected all versions; fixed in 8.6.77
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.1
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.1
- parse (Bitnami): affected all versions; fixed in 8.6.77, 9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47138/ (Markdown: https://insights.sbomify.com/CVE-2026-47138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47138
- OSV: https://osv.dev/vulnerability/CVE-2026-47138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47138/
Summaries are generated and may contain mistakes; the official description above is the record.
