# CVE-2026-47139: vm2: NodeVM network builtin exclusions bypass via internal _http_client and _http_server

> Attackers can bypass network restrictions in vm2 NodeVM by accessing internal HTTP builtins, allowing unauthorized outbound requests and socket listening.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** ECHO-639f-b736-8c56, GHSA-r9pm-gxmw-wv6p, MINI-mmhw-7vqp-f7v9, ROOT-APP-NPM-CVE-2026-47139

## What is CVE-2026-47139?

CVE-2026-47139 is a high-severity vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, NodeVM supports excluding public network builtins from the wildcard builtin option. With this configuration direct access to http, https, http2, net, dgram, tls, dns, and dns/promises is blocked. However, Node.js also exposes underscored internal HTTP builtins such as _http_client and _http_server. These are not blocked when the public modules are excluded. Sandboxed code can use these internal builtins to make outbound HTTP requests and open listening HTTP sockets even though the public network modules are denied. This issue has been patched in version 3.11.4.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-47139?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.4 |
| `vm2` | npm | All versions | 3.11.4 |

## How do I fix CVE-2026-47139?

Upgrade vm2 to 3.11.4 or later.

## Is CVE-2026-47139 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47139 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47139 and fix it if it is affected.

What it is: CVE-2026-47139 is a high-severity vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47139 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.4
- vm2 (npm): affected all versions; fixed in 3.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47139/ (Markdown: https://insights.sbomify.com/CVE-2026-47139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47139
- OSV: https://osv.dev/vulnerability/CVE-2026-47139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47139/
Summaries are generated and may contain mistakes; the official description above is the record.
