# CVE-2026-47140: vm2: NodeVM builtin denylist bypass via process and inspector/promises allows host code execution

> Attackers can bypass sandbox restrictions in vm2 to execute arbitrary code on the host system by accessing missing builtins.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 13 Jun 2026
- **Also known as:** ECHO-cb10-a83c-3146, GHSA-rp36-8xq3-r6c4, MINI-m857-ffj4-2fgq, ROOT-APP-NPM-CVE-2026-47140

## What is CVE-2026-47140?

CVE-2026-47140 is a critical code injection vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, NodeVM blocks several dangerous Node.js builtins such as module, worker_threads, cluster, vm, repl, and inspector. However, the denylist misses process and inspector/promises. Both can be used from sandboxed code to reach host-side execution primitives. This allows sandboxed code to bypass the intended builtin restrictions and execute code in the host process. This issue has been patched in version 3.11.4.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-47140?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.4 |
| `vm2` | npm | All versions | 3.11.4 |

## How do I fix CVE-2026-47140?

Upgrade vm2 to 3.11.4 or later.

## Is CVE-2026-47140 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47140 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47140 and fix it if it is affected.

What it is: CVE-2026-47140 is a critical code injection vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47140 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.4
- vm2 (npm): affected all versions; fixed in 3.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47140/ (Markdown: https://insights.sbomify.com/CVE-2026-47140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47140
- OSV: https://osv.dev/vulnerability/CVE-2026-47140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47140/
Summaries are generated and may contain mistakes; the official description above is the record.
