# CVE-2026-47141: vm2: NodeVM observability builtins leak host process and HTTP request data

> Sandboxed code can leak host process and HTTP data via observability builtins if require.builtin is configured to allow them.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 13 Jun 2026
- **Also known as:** ECHO-4102-701c-2063, GHSA-9g8x-92q2-p28f, MINI-6qmh-9p38-8276, ROOT-APP-NPM-CVE-2026-47141

## What is CVE-2026-47141?

CVE-2026-47141 is a medium-severity vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, NodeVM exposes some process-wide observability builtins when they are allowed through require.builtin. The diagnostics_channel, async_hooks, and perf_hooks builtins are not blocked by the dangerous builtin denylist. These modules are process-wide, not sandbox-local. Sandboxed code can use them to observe host application data across the vm2 boundary. This issue has been patched in version 3.11.4.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-47141?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.4 |
| `vm2` | npm | All versions | 3.11.4 |

## How do I fix CVE-2026-47141?

Upgrade vm2 to 3.11.4 or later.

## Is CVE-2026-47141 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47141 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47141 and fix it if it is affected.

What it is: CVE-2026-47141 is a medium-severity vulnerability in patriksimek vm2, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47141 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.4
- vm2 (npm): affected all versions; fixed in 3.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47141/ (Markdown: https://insights.sbomify.com/CVE-2026-47141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47141
- OSV: https://osv.dev/vulnerability/CVE-2026-47141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47141/
Summaries are generated and may contain mistakes; the official description above is the record.
