# CVE-2026-47155: vLLM: Artifact Pin Decay in vLLM allows pinned deployments to load unpinned code, weights, and processors

> Attackers can inject malicious code or weights into pinned vLLM deployments by exploiting inconsistent revision pinning for nested artifacts.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-3ww4-5jv9-j5gm, MINI-265m-796r-j4h6, MINI-4gx2-8qxv-64x8, MINI-9m3h-gjv4-v4j8, PYSEC-2026-2301

## What is CVE-2026-47155?

CVE-2026-47155 is a medium-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.0, vLLM's revision pinning controls do not consistently apply to all artifacts loaded for a model. A deployment that supplies --revision or --code-revision can still load dynamic code, GGUF files, image processors, retrieval side weights, or same-repository subfolder weights/config from an unpinned/default revision. This is a supply-chain integrity issue for pinned vLLM deployments. Operators can believe they are serving a reviewed model revision while vLLM resolves behavior-affecting nested or sibling artifacts outside that reviewed revision. This vulnerability is fixed in 0.22.0.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-47155?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.22.0 |
| `vllm` | PyPI | All versions | 0.22.0 |
| `vllm` | PyPI | All versions | 0.22.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-47155?

Upgrade vllm to 0.22.0 or later.

## Is CVE-2026-47155 being exploited?

There is no known exploitation of CVE-2026-47155 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47155 and fix it if it is affected.

What it is: CVE-2026-47155 is a medium-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47155 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.22.0
- vllm (PyPI): affected all versions; fixed in 0.22.0
- vllm (PyPI): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47155/ (Markdown: https://insights.sbomify.com/CVE-2026-47155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47155
- OSV: https://osv.dev/vulnerability/CVE-2026-47155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47155/
Summaries are generated and may contain mistakes; the official description above is the record.
