CVE-2026-47156 MantisBT: SOAP API Authentication Bypass with Privilege Escalation to Administrator

Critical 9.3 Published Updated

Attackers can bypass SOAP API authentication to impersonate administrators and escalate privileges in MantisBT installations with default settings.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-47156?

CVE-2026-47156 is a critical authentication bypass vulnerability in mantisbt, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MantisBT is an open source bug tracker. Versions 2.28.3 and earlier contain a critical authentication bypass in the SOAP API's mci_check_login() function. Any user knowing any valid cookie_string can authenticate as any other user (knowing their username), including the administrator, without knowing the target's password. The vulnerability is exploitable with zero prior access on default MantisBT installations because self-registration is enabled by default ($g_allow_signup = ON). A self-registered user can use their own cookie_string (readable from their browser's MANTIS_STRING_COOKIE cookie after login) to impersonate the administrator via the SOAP API. The REST API is NOT affected. The REST API's AuthMiddleware derives the username server-side from the API token or session cookie, so the username cannot be spoofed. The Web UI is NOT affected. The Web UI authenticates via PHP session cookies (PHPSESSID) and validates the MANTIS_STRING_COOKIE against the logged-in user through auth_is_cookie_valid(). The username is derived server-side from the cookie, not supplied by the client. Version 2.28.4 contains a patch. No known workarounds are available.

Weakness: CWE-639, CWE-287

Which versions are affected by CVE-2026-47156?

2 open source packages ship an affected version, including mantisbt/mantisbt.

PackageAffectedFixed in
mantisbt/mantisbt PackagistAll versions2.28.4
mantisbt/mantisbt PackagistAll versions2.28.4

How do I fix CVE-2026-47156?

Upgrade mantisbt/mantisbt to 2.28.4 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-47156 being exploited?

There is no known exploitation of CVE-2026-47156 in the wild and no public exploit code.

Sources

Also known as GHSA-c2xg-qjqw-2v98.

Is CVE-2026-47156 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free