# CVE-2026-47157: aiograpi: Unsafe signup challenge path handling

> Attackers can force the library to send requests to arbitrary hosts with session headers by manipulating challenge paths, potentially leaking data or bypassing security controls.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-jh37-x3fv-4x72, PYSEC-2026-2337

## What is CVE-2026-47157?

CVE-2026-47157 is a medium-severity server-side request forgery vulnerability in subzeroid aiograpi, published on 11 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

aiograpi is an asynchronous Instagram API for Python. aiograpi versions before 0.9.10 accepted server-supplied signup challenge paths and used them to build request URLs before validating that the paths were relative Instagram API paths. If an attacker can influence a challenge response, for example through a local network, DNS, or proxy compromise, challenge handling requests could be sent outside the intended Instagram host with the client's existing session headers. Version 0.9.10 validates challenge paths before building URLs, solving captcha challenges, or submitting phone/SMS challenge forms.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-47157?

3 open source packages ship an affected version, including aiograpi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiograpi` | PyPI | All versions | 0.9.10 |
| `aiograpi` | PyPI | All versions | 0.9.10 |
| `aiograpi` | PyPI | All versions | 0.9.10 |

## How do I fix CVE-2026-47157?

Upgrade aiograpi to 0.9.10 or later.

## Is CVE-2026-47157 being exploited?

There is no known exploitation of CVE-2026-47157 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47157 and fix it if it is affected.

What it is: CVE-2026-47157 is a medium-severity server-side request forgery vulnerability in subzeroid aiograpi, published on 11 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47157 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiograpi (PyPI): affected all versions; fixed in 0.9.10
- aiograpi (PyPI): affected all versions; fixed in 0.9.10
- aiograpi (PyPI): affected all versions; fixed in 0.9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47157/ (Markdown: https://insights.sbomify.com/CVE-2026-47157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47157
- OSV: https://osv.dev/vulnerability/CVE-2026-47157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47157/
Summaries are generated and may contain mistakes; the official description above is the record.
