{"answers":{"affected":"2 open source packages ship an affected version, including paymenter/paymenter.","exploited":"There is no known exploitation of CVE-2026-47198 in the wild and no public exploit code.","fix":"Upgrade paymenter/paymenter to 1.5.1 or later.","what":"CVE-2026-47198 is a high-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-47198 and fix it if it is affected.\n\nWhat it is: CVE-2026-47198 is a high-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-47198 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.1\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47198/ (Markdown: https://insights.sbomify.com/CVE-2026-47198/index.md)","id":"CVE-2026-47198","markdown":"https://insights.sbomify.com/CVE-2026-47198/index.md","name":"CVE-2026-47198","record":{"aliases":["GHSA-5q4q-834j-g8g4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Hosting management platform","requires_auth":"low_privilege","summary":"Authenticated users can inject URL parameters to override administrator-defined hosting resource limits and plan tiers during checkout.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.1, the checkout component improperly filters URL-writable properties, allowing authenticated users to inject arbitrary key-value pairs into server provisioning parameters. Because bundled server extensions prioritize these user-supplied properties over administrator-defined configurations, a regular user can override hosting plans and resource limits at checkout without special privileges. The Checkout Livewire component's $checkoutConfig property exposed via URL query parameters, only validating keys explicitly defined by an extension's configuration method, allowing any undefined injected keys to bypass validation entirely. These unsanitized keys are then stored directly in the database by the cart component and later passed to server extensions during provisioning, enabling user-injected data to override intended administrator settings. Depending on the active extension, this leads to unauthorized overrides of core resource limits (such as CPU, RAM, storage, or package tiers). No administrative privileges are required to exploit this vulnerability. This issue has been fixed in version 1.5.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paymenter: URL parameter injection bypasses paid plan limits at checkout","id":"CVE-2026-47198","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Frappe: check_safe_sql_query Permits SELECT INTO OUTFILE","id":"CVE-2026-47199"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":null,"source":"GHSA-5q4q-834j-g8g4"},{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":"pkg:composer/paymenter/paymenter","source":"GHSA-5q4q-834j-g8g4"}],"prev":{"headline":"Quest Bot: Discord moderation role hierarchy bypass in ban, kick, mute, unmute, warn, and nickname commands","id":"CVE-2026-47197"},"products":["Paymenter"],"published":"2026-07-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-22","vendors":["Paymenter"]},"summary":"Authenticated users can inject URL parameters to override administrator-defined hosting resource limits and plan tiers during checkout.","url":"https://insights.sbomify.com/CVE-2026-47198/"}