# CVE-2026-47200: Nuxt: Route middleware not enforced when rendering `.server.vue` pages via `/__nuxt_island/page_*`

> Attackers can bypass route middleware protections on server island pages in Nuxt when experimental component islands are enabled.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 13 Jun 2026
- **Also known as:** GHSA-hg3f-28rg-4jxj

## What is CVE-2026-47200?

CVE-2026-47200 is a medium-severity missing authorization vulnerability in nuxt, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nuxt is an open-source web development framework for Vue.js. In Nuxt versions 3.11.0 to before 3.21.6 and 4.0.0-alpha.1 to before 4.4.6 and @nuxt/nitro-server versions 3.20.0 to before 3.21.6 and 4.0.0-alpha.1 to before 4.4.6, when experimental.componentIslands is enabled (default in Nuxt 4), any .server.vue file under pages/ is automatically registered as a server island under the key page_<routeName> and exposed via the /__nuxt_island/:name endpoint. Until this fix, requests through that endpoint rendered the page component directly via the SSR renderer without instantiating Vue Router, which meant route middleware declared on the page (including definePageMeta({ middleware })) did not run. This issue has been patched in versions 3.21.6 and 4.4.6.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-47200?

8 open source packages ship an affected version, including @nuxt/nitro-server and nuxt. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nuxt/nitro-server` | npm | From 3.20.0 | 3.21.6 |
| `@nuxt/nitro-server` | npm | From 3.20.0 | 3.21.6 |
| `@nuxt/nitro-server` | npm | From 4.2.0 | 4.4.6 |
| `@nuxt/nitro-server` | npm | From 4.2.0 | 4.4.6 |
| `nuxt` | npm | From 3.11.0 | 3.21.6 |
| `nuxt` | npm | From 3.11.0 | 3.21.6 |
| `nuxt` | npm | From 4.0.0-alpha.1 | 4.4.6 |
| `nuxt` | npm | From 4.0.0-alpha.1 | 4.4.6 |

Products: Nuxt Nuxt, Nuxt Nuxt\/Nitro-Server.

## How do I fix CVE-2026-47200?

Upgrade @nuxt/nitro-server to a fixed version for your release line: 3.21.6 or 4.4.6.

## Is CVE-2026-47200 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47200 exists.

## Other vulnerabilities in nuxt

- [CVE-2026-53721](https://insights.sbomify.com/CVE-2026-53721/): Nuxt: Route-rule middleware bypass via case-sensitivity mismatch between vue-router and the routeRules matcher (high 8.8)
- [CVE-2024-23657](https://insights.sbomify.com/CVE-2024-23657/): Path Traversal: '../filedir' in Nuxt Devtools (high 8.8)
- [CVE-2024-34344](https://insights.sbomify.com/CVE-2024-34344/): Remote code execution via the browser when running the test locally in nuxt (high 8.8)
- [CVE-2024-42352](https://insights.sbomify.com/CVE-2024-42352/): Server-Side Request Forgery (SSRF) in nuxt-icon (high 8.6)
- [CVE-2023-3224](https://insights.sbomify.com/CVE-2023-3224/): Code Injection in nuxt/nuxt (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47200 and fix it if it is affected.

What it is: CVE-2026-47200 is a medium-severity missing authorization vulnerability in nuxt, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47200 exists.

Affected packages and fixed versions:
- @nuxt/nitro-server (npm): affected from 3.20.0; fixed in 3.21.6
- @nuxt/nitro-server (npm): affected from 3.20.0; fixed in 3.21.6
- @nuxt/nitro-server (npm): affected from 4.2.0; fixed in 4.4.6
- @nuxt/nitro-server (npm): affected from 4.2.0; fixed in 4.4.6
- nuxt (npm): affected from 3.11.0; fixed in 3.21.6
- nuxt (npm): affected from 3.11.0; fixed in 3.21.6
- nuxt (npm): affected from 4.0.0-alpha.1; fixed in 4.4.6
- nuxt (npm): affected from 4.0.0-alpha.1; fixed in 4.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47200/ (Markdown: https://insights.sbomify.com/CVE-2026-47200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47200
- OSV: https://osv.dev/vulnerability/CVE-2026-47200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47200/
Summaries are generated and may contain mistakes; the official description above is the record.
