# CVE-2026-47211: Ouroboros: Remote Code Execution via Untrusted Project-Directory .env

> Attackers can execute arbitrary code by placing a malicious .env file in a cloned repository, tricking users into running the tool.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-c4m7-2gwp-vw76, PYSEC-2026-2857

## What is CVE-2026-47211?

CVE-2026-47211 is a high-severity code injection vulnerability in Q00 ouroboros, published on 3 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Ouroboros is a local-first runtime for AI coding agents that records their actions and applies user-defined policies to constrain behavior. In versions prior to 0.39.0, if a user clones a malicious repository and runs Ouroboros commands within that directory, it can lead to arbitrary code execution and potential system takeover. The vulnerability stems from Ouroboros loading the .env file from the current working directory. Execution-affecting environment variables such as OUROBOROS_CLI_PATH, OPENCODE_CLI_PATH, and other backend selectors are accepted directly from this local .env. An attacker can include a malicious script in the repository and point the CLI path variable to it (e.g., OUROBOROS_CLI_PATH=./malicious_script.sh). When the user executes a command like ouroboros init or any command that instantiates the adapter, the malicious script is executed instead of the intended CLI. This issue has been fixed in version 0.39.0.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-47211?

3 open source packages ship an affected version, including ouroboros-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ouroboros-ai` | PyPI | All versions | 0.39.0 |
| `ouroboros-ai` | PyPI | All versions | 0.39.0 |
| `ouroboros-ai` | PyPI | All versions | 0.39.0 |

## How do I fix CVE-2026-47211?

Upgrade ouroboros-ai to 0.39.0 or later.

## Is CVE-2026-47211 being exploited?

There is no known exploitation of CVE-2026-47211 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47211 and fix it if it is affected.

What it is: CVE-2026-47211 is a high-severity code injection vulnerability in Q00 ouroboros, published on 3 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47211 in the wild and no public exploit code.

Affected packages and fixed versions:
- ouroboros-ai (PyPI): affected all versions; fixed in 0.39.0
- ouroboros-ai (PyPI): affected all versions; fixed in 0.39.0
- ouroboros-ai (PyPI): affected all versions; fixed in 0.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47211/ (Markdown: https://insights.sbomify.com/CVE-2026-47211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47211
- OSV: https://osv.dev/vulnerability/CVE-2026-47211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47211/
Summaries are generated and may contain mistakes; the official description above is the record.
